Announcement Announcement Module
Collapse
No announcement yet.
Problem to install maven scm handler for egit in STS 3.0.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem to install maven scm handler for egit in STS 3.0.0

    Hello

    When i try to install maven scm handler for egit from the m2e marketplace i receive this error.

    i am using sts 3.0.0

    Francis


    Cannot complete the install because one or more required items could not be found.
    Software being installed: Maven SCM Handler for EGit 0.14.0.201110251725 (org.sonatype.m2e.egit.feature.feature.group 0.14.0.201110251725)
    Missing requirement: Maven SCM Handler for EGit 0.14.0.201110251725 (org.sonatype.m2e.egit 0.14.0.201110251725) requires 'bundle org.eclipse.egit.core [1.0.0,2.0.0)' but it could not be found
    Cannot satisfy dependency:
    From: Maven SCM Handler for EGit 0.14.0.201110251725 (org.sonatype.m2e.egit.feature.feature.group 0.14.0.201110251725)
    To: org.sonatype.m2e.egit [0.14.0.201110251725]

  • #2
    Hey Francis!

    This error message says that the component that you would like to install (sonatype m2e egit connector) requires EGit in version 1.x.x. The EGit version that was shipped as part of Juno (and is therefore included in STS 3.0.0) is 2.0.0, so it seems like the Marketplace entry for the Maven SCM Handler for EGit is not compatible with the latest Eclipse Juno release.

    This is the same as reported here:
    http://stackoverflow.com/questions/1...-egit-for-juno

    and I think the second comment points to a repository with an updated EGit connector for Juno.

    HTH,
    -Martin

    Comment

    Working...
    X