Announcement Announcement Module
Collapse
No announcement yet.
STS & GGTS 3.1.0.M1 released Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS & GGTS 3.1.0.M1 released

    Dear Spring Community,

    I am happy to announce the first milestone release 3.1.0.M1 of the Spring Tool Suite (STS) and the Groovy/Grails Tool Suite (GGTS).

    Highlights from this milestone include:
    • We now provide distributions based on Eclipse 3.8 and Eclipse 4.2
    • Mylyn updated to 3.8.1
    • Mac apps now signed for Gatekeeper in OSX 10.8 Mountain Lion
    • Maven support for Grails projects
    Some of our users reported general performance issues with the new Eclipse Juno 4.2 platform that STS 3.0.0 ships with. Most of these issues seem to be related to the underlying UI platform and its usage from various plugins and extensions. Since our goal is to provide the best possible user experience, we decided to provide two separate distributions for STS 3.1.0.M1: one that is built on top of Eclipse Juno 3.8 and one on top of Eclipse Juno 4.2. People who have trouble using the 4.2-based version should try the 3.8-based distribution instead.

    The 3.1.0 release is planned to arrive shortly after the Eclipse Juno SR1 release and will also provide both distributions.

    More details can be found in the New and Noteworthy for 3.1.0.M1 document.

    To download the distributions, please go visit:
    Detailed new and noteworthy notes can be found here: STS/GGTS 3.1.0.M1 New & Noteworthy

    3.1.0.RELEASE is planned for the week of October 8th.

    Enjoy!
    The SpringSource tooling team

  • #2
    And please see my new post on working with mavenized grails projects.

    Comment


    • #3
      I've just successfully installed Spring Tool Suite (STS) for Eclipse Juno (4.2) Version: 3.0.0.201208090952-RELEASE from the Eclipse Marketplace.

      Is it just me, or is the Eclipse Marketplace version missing any vfabric-tc-server-developer?
      In case tc Server is missing from the Eclipse Marketplace version, will you add it to the upcoming STS Eclipse Juno (4.2) 3.1.0.RELEASE Eclipse Marketplace version?

      Thanks!
      Last edited by Eduard; Sep 19th, 2012, 12:57 PM.

      Comment


      • #4
        Hey!

        The vFabric tc Server Integration for Eclipse is part of the Marketplace install and you should have it installed if you installed the Spring Tool Suite (STS) for Juno from the Eclipse Marketplace. However, the tc Server Developer Edition itself is not yet available from the Marketplace. Since it is freely available for developer work, it is not open-source. You can download it from the, I think: https://www.vmware.com/go/vfabric-tcserver-dev

        But I agree that it would be nice to also get that from the Marketplace when you install STS. We will take a look if that is possible in the future.

        Thanks for the feedback!
        -Martin

        Comment

        Working...
        X