Announcement Announcement Module
Collapse
No announcement yet.
STS 3.0 cannot be installed on Eclipse 3.8.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.0 cannot be installed on Eclipse 3.8.0

    I want to install STS on Eclipse 3.8.0, because of a drastic performance decrease in 4.2 specially it's new UI model. I downloaded and installed classic eclipse 3.8.0 and installed WTP and m2e on it.

    Now when I want to install STS 3.0, I first told that atlassian connector is required. After installing atlassian connector no I receive the following errors which prevent installing STS:

    Code:
    Cannot complete the install because of a conflicting dependency.
      Software being installed: Spring Tool Suite Package 3.0.0.201208091018-RELEASE-e42 (org.springsource.sts.package.feature.group 3.0.0.201208091018-RELEASE-e42)
      Software currently installed: Eclipse Platform 3.8.0.I20120608-1200 (org.eclipse.platform.ide 3.8.0.I20120608-1200)
      Only one of the following can be installed at once: 
        Eclipse Platform 4.2.0.v201206081400 (org.eclipse.platform 4.2.0.v201206081400)
        Eclipse Platform 3.8.0.v201206081200 (org.eclipse.platform 3.8.0.v201206081200)
      Cannot satisfy dependency:
        From: Eclipse Platform 3.8.0.v20120607-071945-9gF7jI7nG5qByXMVdkhRMWBQlF4PnDCLybDCPQ (org.eclipse.platform.feature.group 3.8.0.v20120607-071945-9gF7jI7nG5qByXMVdkhRMWBQlF4PnDCLybDCPQ)
        To: org.eclipse.platform [3.8.0.v201206081200]
      Cannot satisfy dependency:
        From: Eclipse Platform 4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb (org.eclipse.platform.feature.group 4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb)
        To: org.eclipse.platform [4.2.0.v201206081400]
      Cannot satisfy dependency:
        From: Eclipse Platform 3.8.0.I20120608-1200 (org.eclipse.platform.ide 3.8.0.I20120608-1200)
        To: org.eclipse.platform.feature.group [3.8.0.v20120607-071945-9gF7jI7nG5qByXMVdkhRMWBQlF4PnDCLybDCPQ]
      Cannot satisfy dependency:
        From: Spring Tool Suite Package 3.0.0.201208091018-RELEASE-e42 (org.springsource.sts.package.feature.group 3.0.0.201208091018-RELEASE-e42)
        To: org.eclipse.platform.feature.group [4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb]

  • #2
    It's fixed. The only offensive package was:
    Spring Tool Suite Package 3.0.0.201208091018-RELEASE-e42

    When I deselected it, everything installed.

    Thanks.

    Comment


    • #3
      Hey!

      Glad to hear you got it working!!!
      The package feature that you mentioned is indeed specific for Eclipse 4.2 (because it includes the Eclipse platform feature in version 4.2). But you also don't really need this in order to get everything installed - as you figured out... :-)

      Cheers,
      -Martin

      Comment

      Working...
      X