Announcement Announcement Module
Collapse
No announcement yet.
Maven filtering (token substitution)/Eclipse (STS)Version: 2.9.2./ Tomcat not working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maven filtering (token substitution)/Eclipse (STS)Version: 2.9.2./ Tomcat not working

    I have a Webapp which I build using Maven with the following parameters : goals: -e clean package install profiles :env-test

    This runs fine and and installs the proper code including the filtered information from the profiles correctly to the "target" directories.

    My problem is when I "publish" to the tomcat server, it seems to publish from the resource directory and not the target directories which means I get my property files with all the variable names in them instead of the converted variables which have been completed in the target directories.

    How can I get it to publish the Maven build files which were built correctly?

    Any direction would be greatly appreciated.

  • #2
    I have the same exact problem, but I am using STS version 3.0.0.RELEASE.

    Comment


    • #3
      Hey!

      Did you take a look at the "Deployment Assembly" properties of your project? Since there is an integration between WTP tooling in Eclipse and the Maven Integration into the IDE, I think it tries to deploy from your workspace (so that you typically don't need to trigger a Maven build manually). Maybe the "Deployment Assembly" settings help here. Sorry for just guessing here, but I hope it helps nonetheless...

      -Martin

      Comment

      Working...
      X