Announcement Announcement Module
Collapse
No announcement yet.
STS 3.0.0 - Spring Data support - can i change error level of Invalid derived Query! Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.0.0 - Spring Data support - can i change error level of Invalid derived Query!

    STS 3.0.0 support code complete and validation for repository method. Best for normal case

    However, i am using custom factory for the repository and some of the method name are not follow the method name of repository. Therefore, i got some "Invalid derived Query! ...." Error annotation.

    How can i change the error level of "Invalid derived Query! ...." ?!

  • #2
    No, currently you can't. In how far would that make sense? The query method is invalid and the ApplicationContext containing would not be bootstrappable either.

    Comment


    • #3
      I am using custom factory for repository and QueryLookupStrategy to extend the functions of Spring Data JPA with our own proprietary DAO function. If the method is annotation with our own annotation, our proprietray DAO method will be used. Otherwise, use the original Spring Data JPA way. If i cannot change the error level of "Invalid derived Query! ...." (e.g. to warning), i may not use STS 3.

      Comment


      • #4
        Would you mind creating a ticket in the Spring IDE JIRA? In general the error marker should not affect the actual running project, it's rather an IDE indicator only.

        Comment

        Working...
        X