Announcement Announcement Module
Collapse
No announcement yet.
STS 3.0 - MercurialEclipse view exceptions Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.0 - MercurialEclipse view exceptions

    Hi

    Trying to use view a project history in STS 3.0 and getting the following exception.
    Code:
    An error has occurred. See error log for more details.
    com.vectrace.MercurialEclipse.history.GraphLogTableViewer cannot be cast to org.eclipse.ui.part.PageBookView$SelectionProvider
    MercurialEclipse version is 1.9.1.v201111302231

    This worked fine in STS 2.9.2.

    David/

  • #2
    Hey David!

    I guess that the version of MercurialEclipse that you are using is not yet compatible with Eclipse Juno 4.2 (the version that STS 3.0.0 is based on). I would recommend to install MercurialEclipse 2.0.0, which is mentioned on the webpage to be compatible with Eclipse 4.2.

    HTH,
    Martin

    Comment


    • #3
      Thanks Martin, your solution did work.
      For anyone else make sure your version of kilnclient is compatible with MercurialEclipse 2.0.0, I had an old version installed and they were not compatible. So I had to uninstall the kilnclient and install newer version before MercurialEclipse 2.0.0 would work.

      Comment


      • #4
        Hey!

        Glad to hear its working with the new version and thanks for letting us know!!!

        Cheers,
        -Martin

        Comment


        • #5
          Hi guys,

          I had the same issue as David (error after selecting "Show History"). I'm using: GGTS 3.0 and MercurialEclipse 1.9.1
          After I updated MercurialEclipse to 2.0.0, I'm getting a different error:

          Code:
          Unsupported hg version:1.8.3. Expected is at least2.0.0.
          	at com.vectrace.MercurialEclipse.MercurialEclipsePlugin.checkHgVersion(MercurialEclipsePlugin.java:274)
          	at com.vectrace.MercurialEclipse.MercurialEclipsePlugin.checkHgInstallation(MercurialEclipsePlugin.java:218)
          	at com.vectrace.MercurialEclipse.MercurialEclipsePlugin$1.run(MercurialEclipsePlugin.java:155)
          	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
          Caused by: java.lang.Exception: Unsupported hg version:1.8.3. Expected is at least2.0.0.
          	at com.vectrace.MercurialEclipse.exception.HgException.<init>(HgException.java:49)
          	... 4 more
          Has anyone encountered this?

          Comment


          • #6
            Resolved the issue.

            Of course, apart from updating the MercurialEclipse plugin, I had to update the Mercurial client, installed on my machine:
            http://mercurial.selenic.com/downloads/

            Comment


            • #7
              Hey!

              Thanks for letting us know how you solved the problem!
              This could be very helpful for other forum users!!!

              Thanks,
              Martin

              Comment

              Working...
              X