Announcement Announcement Module
Collapse
No announcement yet.
TC Server timeout when using AJP Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • TC Server timeout when using AJP

    Hey guys, I'm working on a project in STS and when deploying it to a TC Server with AJP the server starts up but then timesout when the time out happens. It's happening on both my Windows and Linux laptop, but I don't see anyone else with the issues. Does anyone know why this is happening? I'd really like to be able to change JSPs without stopping and starting the server (and since eclipse still thinks the server is starting it hangs, even though it's started and works completely).

  • #2
    Hey!

    I tried to create a server instance with AJP included as well and it seems to get created correctly. I can start it without any timeouts... What templates did you select exactly?

    And what happens when you create such an instance from the command line in the tc Server installation and start the server from there? (Not saying you should do that all the time, just trying to figure out where the problem might me...)

    -Martin

    Comment


    • #3
      Hey Martin,
      Sorry about the late reply! Been dealing with other issues all week, just circling around to this.
      The server says it starts but if you check eclipse it says it still is starting (even though the app is running fine) till the 120second timeout. What I might suggest for a real test is start it and go do something then come back and test it (unless you did that and it didn't time out). But I promise you it looks like it's fully functioning till you try to either change a jsp and it tries to publish it or you are testing something that takes more than 2 minutes.

      I haven't tried from command line honestly, I'm going to check that out, but even if it works fine (my guess is it won't) I'll still have the problem in STS . It does this on multiple laptops with the latest version of STS so I'm assuming it's not just me but I

      Comment


      • #4
        Hey!

        I will take a closer look at your steps and try to see if I can reproduce that.
        The idea with the command line was more meant to identify the problem than to propose a workaround. Would just be good to see if the problem is related to the AJP or tc Server part or totally inside STS - as a step to investigate where the problem is.

        -Martin

        Comment


        • #5
          It doesn't timeout in ctl and allows me to republish, so it looks like it might be something to do with the hooks between tc server and STS.

          Comment


          • #6
            I'm able to reproduce it so I have created a new issue for it. Feel free to add yourself as a watcher.

            Cheers,

            Comment

            Working...
            X