Announcement Announcement Module
Collapse
No announcement yet.
STS 3.0 (Really, Eclipse Juno) is slow... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.0 (Really, Eclipse Juno) is slow...

    I had tried Eclipse Juno standalone before and noticed it was quite slow, I was hoping that when STS 3.0 was released that this would not be the case still ... but it is.

    By slow, I mean that general code navigation (exploring packages when location is linked to the editor, using CTRL+SHIFT+T / CTRL+SHIFT+R to search, or amusingly... just closing an editor window) are all very slow operations compared to Eclipse 3.x.

    So slow that I can work much at a faster pace then the IDE is capable of, and my development machine is no slouch (Core i7 quad core with > 3GHz / Win7 / 8 GB RAM / 256GB SSD).

    I've tried running the IDE using both the latest JDK 6 and JDK 7 releases (jdk1.6.0_33 and jdk1.7.0_05) with no improvement.

    Has anyone else noticed this? Any suggestions to improve the overall performance of Eclipse 4.2? Surprisingly I have not seen much complaining about this when searching, so I'm a bit worried it's specific to my machine.. But I have done all the usual things to ensure speediness, including updating relevant drivers (video, etc) to try to ensure there's not something old somewhere causing slow screen painting, etc.

    Thanks,

  • #2
    Really have no problem with Juno or STS 3.
    But it's true from time to time STS is getting slower and slower. I think it's related to each time I restart my server in WTP but I have no evidence for that.
    When too painful I restart it and it's speedy again.

    PS: I have pretty much the same dev machine minus the SSD (I'm jealous).

    Comment


    • #3
      Then I'll have to fiddle some more, definitely not my imagination, but it is the painting that seems like it's the problem.

      Could be graphics related I suppose...

      And an SSD is an absolute must; builds with hundreds to thousands of classes to compile and files to copy go many factors faster
      Last edited by asherwin; Aug 14th, 2012, 04:05 PM.

      Comment


      • #4
        Hey!

        Can you observe the memory consumption a bit (enable the "show heap status" in the general preferences) to see if this slowness is related to memory issues or GC? Just in case...

        -Martin

        Comment


        • #5
          +1

          Definitely more sluggish 3.0.0 compared to 2.9.2. Same experience for me and my teammate, will enable 'show heap status'.
          (win7 64bit, 8GB, Intel i7 2.8 ghz, 256 gb SSD)

          br
          Svante
          Originally posted by Martin Lippert View Post
          Hey!

          Can you observe the memory consumption a bit (enable the "show heap status" in the general preferences) to see if this slowness is related to memory issues or GC? Just in case...

          -Martin

          Comment


          • #6
            Yeah, please let us know what the heap status will look like. Just wondering if this is memory-related...
            Thanks!

            -Martin

            Comment


            • #7
              My setting

              My setting(eclipse.ini) is below(win7 64bit, 16GB RAM, Core i7 Quad 3.40GHz, 128GB SSD, JDK1.6.0_32).

              -Xms4096m
              -Xmx8192m
              -Xmn2048m
              -Xss4m
              -XX:MaxPermSize=1024m
              -XX:+UseConcMarkSweepGC
              -XX:+CMSIncrementalMode
              -XX:CMSInitiatingOccupancyFraction=75
              -XX:+UseStringCache
              -XX:+OptimizeStringConcat
              -XX:+UseCompressedStrings

              but still slow...
              please advise me, thanks.

              Comment


              • #8
                Hey!

                This looks like an awesome configuration (I wish I had that much power on my machine here). I don't know if it makes sense to run STS/Eclipse with 8GB on max heap size (I am usually fine with less than 1,5GB), but that should not cause a slowdown, I guess. But I would reduce those settings anyway, just in case.

                Since those settings doesn't seem to be responsible for your slowdown, we need to go for further performance analysis here. Is there anything that is getting slow in specific (when do hit a certain button, do something specific, etc.) or just in general? And is it just slower, or really causing this kind "stop-the-world" behavior where you think nothing happens anymore?

                And is there a significant difference that you observe between STS 2.9.2 and STS 3.0.0 using those same settings for your JVM?

                -Martin

                Comment


                • #9
                  Massive difference, takes minutes to load (just hangs for ages before we even see a progress bar), with general navigation and especially server load almost unbearable, thats Glassfish BTW; exactly the same workspace and settings as 2.9.2 performed well on.

                  Any help or pointers would be greatly received, thanks.

                  Update: even starting with a new workspace does exactly the same, ;(

                  OSX 10.7, 8G, SSD

                  - Stephen
                  Last edited by stephenkerrmurphy; Aug 17th, 2012, 04:15 AM.

                  Comment


                  • #10
                    Hey Stephen!

                    So starting up STS 3.0.0 with a fresh, empty workspace results in minutes to startup on OSX? This is really strange, since I have mostly the same setting here (OSX 10.7/10.8, 8GB, SSD) and it loads almost at the same speed as a fresh 2.9.2 installation.

                    Can you take a few thread dumps (jps to identify the process ID and then jstack with the ID to capture the dump) and attach that to this JIRA issue that I opened:

                    https://issuetracker.springsource.com/browse/STS-2848

                    Maybe that helps to identify why this is different on your machine than on mine...

                    Thanks a lot for your help!
                    -Martin

                    Comment


                    • #11
                      thank you for reply.

                      i think it was not happened "stop-the-world" issue, because my setting used concurrent garbage collection(and G1GC is same behavior).
                      when eclipse start up, it is confortable performance in a few minutes or less than one hour(in the sense of me).
                      after i uses for several tens of minutes, it slowdown in all actions(click something, save file, change perspective, show (context)menu, etc.., i kept waiting about 10 seconds..) every time.

                      now i take a vacation this week, so i can't try memory profiling, comparing STS 2.9.2(indigo) and STS 3.0.0(juno) each other(and same settings).
                      after the vacation, i try that and report.

                      thanks,

                      Comment


                      • #12
                        Hey!

                        It would be great if you could provide some more details about this after your vacation!!!
                        Thank you very much for that in advance!!!

                        Cheers,
                        -Martin

                        Comment


                        • #13
                          Hi all,
                          i have the following issue with 3.0 on OSX (mountain lion)
                          Installed cocoa 64bit version, opened on a new workspace
                          Installed subversive, restarted, installed the svnkit 1.3.7 connector, restarted, hangs forever

                          Retried 2 times more, from scratch, fully repeatable behaviour

                          Cheers
                          Paolo

                          Comment


                          • #14
                            I have recently upgraded to 3.0.0 and I was very excited to use the new version. All went fine and started enjoying the new look and feel (slight blue color theme, and seamless window behaviors etc), but to my surprise it was running extremely slow and it was painful.
                            Just switching to different files (especially xml), it use to take a second or sometimes 2 seconds..
                            I have rolled back to use the older 2.9.2. Definitely some serious issues with performance of the IDE.

                            Comment


                            • #15
                              Hey!

                              We are investigating the performance issues with STS 3.0.0 at the moment and this might be a candidate that causes this:
                              https://bugs.eclipse.org/bugs/show_bug.cgi?id=386070

                              This specific issue is going to be fixed in Eclipse Juno 4.2.1, but maybe we can do something to solve this in existing STS 3.0.0 installations. I will keep you posted.

                              -Martin

                              Comment

                              Working...
                              X