Announcement Announcement Module
Collapse
No announcement yet.
STS/GGTS 3.0.0 FAQ Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS/GGTS 3.0.0 FAQ

    Where can I get the Spring Tool Suite 3.0.0 from? And where the Groovy/Grails Tool Suite 3.0.0?

    You can download the ready-to-use distributions here:
    http://www.springsource.org/sts
    http://grails.org/products/ggts

    If you prefer to use an existing Eclipse Indigo or Juno installation, you can go to the Eclipse Marketplace and install “Spring Tool Suite (STS)” or “Groovy/Grails Tool Suite (GGTS)”. Please take care to grab the right Marketplace entry for your Eclipse version, since we provide different entries for Eclipse Indigo (3.7) and Eclipse Juno (4.2).

    Can I upgrade from an existing STS 2.x to 3.0.0?

    No. You cannot upgrade an existing STS 2.x installation to 3.0.0. It is recommended to start with a fresh installation of STS/GGTS 3.0.0.

    My STS doesn’t show any updates? Why?

    Since it is not possible to upgrade an existing STS 2.x installation to 3.0.0, we disabled this automatic update path. Therefore no updates are shown when you do a “Check for Updates” in your existing STS installation. Please start with a fresh STS/GGTS installation, but you may reuse your old workspace as we describe below.

    Can I open and reuse my old workspace with STS/GGTS 3.0.0?

    Yes, you can. We built-in several migration assistants that help you to migrate project and workspace settings to the new version. However, you cannot use the same workspace simultaneously with STS 2.9.x and STS/GGTS 3.0.0. Once your projects are migrated to the new version, they will no longer be configured properly for STS 2.x. Therefore we recommend (in case you would like to use different versions of STS/GGTS within your team) to not commit those project configuration changes (the .project and .classpath files and the .settings folder) to version control and keep those changes local until everybody has migrated to the new version.

    What version of Eclipse is STS built on?

    STS/GGTS 3.0.0 is compatible with Eclipse Indigo (3.7) and Eclipse Juno (3.8/4.2). The ready-to-use distributions are build on top of Eclipse Juno 4.2.

    I want to use Eclipse 3.7, not 4.2. How can I do that?

    The easiest way to use STS/GGTS with Eclipse 3.7 is to start with a fresh Eclipse Indigo JEE distribution and install the Indigo-compatible version of STS or GGTS from the Eclipse Marketplace.

    Once you have STS or GGTS installed, you can use the SpringSource Dashboard to install additional tooling features, like add the Spring tooling to an GGTS installation or vice versa.

    I want to use Spring tooling together with Groovy/Grails tooling. Is that possible?

    Yes, that is possible. You can combine the individual features into a setting of your own choice. Just start with a distribution and use the Dashboard to install features you would like to add. Due to the componentized nature of STS and GGTS it is now possible to combine those projects on a fine granularity.

    I don’t like the new UI theme in Eclipse 4.2. Can I change that back to the old style?

    Yes, you can switch your STS/GGTS installation back to use the old UI theme. Just go to Window -> Preferences -> General -> Appearance and select the “classic” scheme. Don’t forget to restart after switching the scheme, otherwise you end up having a half-active scheme, which looks worse than before.

    Where can I get support?

    The community forum for STS/GGTS is here:
    http://forum.springsource.org/forumd...rce-Tool-Suite

    The issue/bug tracker is here:
    https://issuetracker.springsource.com/browse/STS

    Commercial support is also available as part of the vFavbric support contracts
    http://www.vmware.com/support/servic...developer.html

    Have any features been removed in the 3.0 release?

    Yes, we remove some outdated and no-longer maintained features from the projects and the distribution, like the VMware Workstation support, tutorial-style cheat sheets, the runtime error analysis and its knowledge base, and the integrations for dm server.

    Support for Eclipse Virgo (previously SpringSource dm Server) is now part of the Eclipse Virgo project itself and can be installed from the Eclipse Marketplace.

    STS and GGTS is open-source now. Where are the projects/sources?

    The projects are hosted on GitHub as part of the SpringSource organization. Please take a look at this blog post to learn more about the individual projects and their location on GitHub.
    http://blog.springsource.org/2012/08...-and-at-github

    How can I contribute to the projects?

    The best way to contribute to the projects is to fork them on GitHub and to submit pull requests. All further work, reviews, and discussions can then be part of this pull request on GitHub. Each project also provides a small “how to contribute” section in its readme.

    For all contributions, we need to make sure that you own the code you are contributing and that you are allowed to contribute this code back to the project (i.e., you have permission from your employer). Therefore you are required to sign a contributor’s agreement. This is also mentioned in the readmes. It is not complicated to fill out and doing so helps us to keep the open-source project in a good legal open-source shape.

    Mac OS is telling me that the STS/GGTS installer can’t be opened because it comes from an unidentified developer. What can I do?

    Mac OS 10.8 Mountain Lion has introduced a new security feature that can limit running applications if they don’t come from the Mac App Store or from an identified developer. We are still working on getting STS/GGTS and its installers signed with an identified Apple developer account. In the meantime, you will have to temporarily bypass this security feature in order to install or launch STS/GGTS 3.0 for the first time.

    Open the System Preferences application, go to the Security & Privacy panel then select the General tab. Under the preference labelled Allow applications downloaded from: select the radio button labelled Anywhere. If this setting is greyed out, you will need to click the lock at the bottom of the panel and enter an admin level password.

    Once you’ve successfully launched STS/GGTS for the first time, you should be able to reset the security setting to its original level if you so choose.

    Mac OS is telling me that STS/GGTS is damaged and can’t be opened. Did I get a bad download?

    We believe this message is also coupled to Mac OS 10.8’s new security feature. Please follow the instructions outlined in the entry above in order to temporarily disable all application restrictions.
    Last edited by Martin Lippert; Sep 30th, 2013, 06:39 AM.

  • #2
    Q: Can I upgrade from an existing STS 3.0 milestone to 3.0.0?
    No. You cannot upgrade any version prior to 3.0.0.RELEASE to 3.0.0. It is recommended to start with a fresh installation of STS/GGTS 3.0.0.

    Comment

    Working...
    X