Announcement Announcement Module
Collapse
No announcement yet.
Cannot install STS server tools in eclipse 3.6 - conflicting dependency Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot install STS server tools in eclipse 3.6 - conflicting dependency

    I get this error. What should I do to be able to install SpringSource tc Server ?

    Cannot complete the install because of a conflicting dependency.
    Software being installed: SpringSource Tool Suite tc Server Tools 2.9.2.201205071000-RELEASE (com.springsource.sts.server.tc.feature.group 2.9.2.201205071000-RELEASE)
    Software currently installed: Mylyn Bridge: Plug-in Development 3.4.3.v20110131-0100-e3x-43-7w31211719012110f4y (org.eclipse.mylyn.pde_feature.feature.group 3.4.3.v20110131-0100-e3x-43-7w31211719012110f4y)
    Only one of the following can be installed at once:
    Mylyn Tasks UI 3.6.2.v20110826-0100 (org.eclipse.mylyn.tasks.ui 3.6.2.v20110826-0100)
    Mylyn Tasks UI 3.6.5.v20120215-0100 (org.eclipse.mylyn.tasks.ui 3.6.5.v20120215-0100)
    Mylyn Tasks UI 3.6.4.v20111117-0100 (org.eclipse.mylyn.tasks.ui 3.6.4.v20111117-0100)
    Mylyn Tasks UI 3.4.2.v20100902-0100-e3x (org.eclipse.mylyn.tasks.ui 3.4.2.v20100902-0100-e3x)
    Mylyn Tasks UI 3.6.3.v20111026-0100 (org.eclipse.mylyn.tasks.ui 3.6.3.v20111026-0100)
    Mylyn Tasks UI 3.6.1.v20110728-0200 (org.eclipse.mylyn.tasks.ui 3.6.1.v20110728-0200)
    Mylyn Tasks UI 3.7.1.v20120425-0100 (org.eclipse.mylyn.tasks.ui 3.7.1.v20120425-0100)
    Mylyn Tasks UI 3.7.0.v20120319-0200 (org.eclipse.mylyn.tasks.ui 3.7.0.v20120319-0200)
    Mylyn Tasks UI 3.4.3.v20110131-0100-e3x (org.eclipse.mylyn.tasks.ui 3.4.3.v20110131-0100-e3x)
    Mylyn Tasks UI 3.4.0.v20100608-0100-e3x (org.eclipse.mylyn.tasks.ui 3.4.0.v20100608-0100-e3x)
    Mylyn Tasks UI 3.6.0.v20110608-1400 (org.eclipse.mylyn.tasks.ui 3.6.0.v20110608-1400)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Workspace Configuration 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.configurator 2.9.2.201205071000-RELEASE)
    To: bundle com.springsource.sts.ide.ui 0.0.0
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (UI) 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.ui 2.9.2.201205071000-RELEASE)
    To: bundle org.eclipse.mylyn.tasks.ui [3.7.0,4.0.0)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite tc Server Tools 2.9.2.201205071000-RELEASE (com.springsource.sts.server.tc.feature.group 2.9.2.201205071000-RELEASE)
    To: com.springsource.sts.server.tc.ui [2.9.2.201205071000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite tc Server Integration (UI) 2.9.2.201205071000-RELEASE (com.springsource.sts.server.tc.ui 2.9.2.201205071000-RELEASE)
    To: bundle com.springsource.sts.ide.configurator 0.0.0
    Cannot satisfy dependency:
    From: Mylyn Task-Focused Interface (Recommended) 3.4.3.v20110131-0100-e3x-777728s73543D6D135332KAv (org.eclipse.mylyn.context_feature.feature.group 3.4.3.v20110131-0100-e3x-777728s73543D6D135332KAv)
    To: org.eclipse.mylyn_feature.feature.group [3.4.3,3.5.0)
    Cannot satisfy dependency:
    From: Mylyn Bridge: Java Development 3.4.3.v20110131-0100-e3x-7D7F-AkF7B77V7c37B775eMp (org.eclipse.mylyn.java_feature.feature.group 3.4.3.v20110131-0100-e3x-7D7F-AkF7B77V7c37B775eMp)
    To: org.eclipse.mylyn.context_feature.feature.group [3.4.3,3.5.0)
    Cannot satisfy dependency:
    From: Mylyn Bridge: Plug-in Development 3.4.3.v20110131-0100-e3x-43-7w31211719012110f4y (org.eclipse.mylyn.pde_feature.feature.group 3.4.3.v20110131-0100-e3x-43-7w31211719012110f4y)
    To: org.eclipse.mylyn.java_feature.feature.group [3.4.3,3.5.0)
    Cannot satisfy dependency:
    From: Mylyn Task List (Required) 3.4.3.v20110131-0100-e3x-7Z7f7AFBBoPbVQ7iNFebXJDypa (org.eclipse.mylyn_feature.feature.group 3.4.3.v20110131-0100-e3x-7Z7f7AFBBoPbVQ7iNFebXJDypa)
    To: org.eclipse.mylyn.tasks.ui [3.4.3.v20110131-0100-e3x]

  • #2
    If you are using Eclipse 3.6, you must use a different update site. Which update site are you using?

    Follow the update site instructions from here:
    http://download.springsource.com/rel....2.RELEASE.pdf

    Make sure to use this bookmarks file:
    http://download.springsource.com/rel.../bookmarks.xml

    Comment


    • #3
      And please also make sure to update to the latest Mylyn version that is compatible with Eclipse 3.6.

      HTH,
      Martin

      Comment


      • #4
        Thank you very very much for the advice. I managed to install STS after updating Mylyn.

        But now I want to run a new maven project on SpringSource ts Server, I cannot open spring perspective, nor can I add my project to my st Server because the project does not show up in my available resource in the Add/Remove option of the st server. How should I do ? I really need to run my project with ts Server.

        I would be thankful if you could give me a little advice.

        Comment


        • #5
          Hey!

          What happens when you try to open the Spring perspective? Do you see an error (maybe in the Error Log view)?
          And when you are using Maven, do you have the Maven Integration for Eclipse installed?

          To avoid all these installation problems, I would recommend to start with a fresh STS 2.9.2 installation, import the project in a clean workspace and try to deploy it then to the auto-configured tc Server instance.

          HTH,
          -Martin

          Comment


          • #6
            I already installed Maven Integration for Eclipse and run several project which did not use Spring and all of them worked. I have installed once again STS 2.9.2, but I have to create for now a new very simple Maven project, using maven-archetype-webapp and add one simple JSP file that will display only "hello world" text, to see if it works. And I should run it with run on server option, but I cannot add this resource to my SpringSource st server so it may run on ts server.

            Comment


            • #7
              I do an Run as->Maven install and then I should run it with Run as->run on server but this run option it doesn't show up, even though the ts server is started... I'm just at the beginning with Maven and do not really know if what I'm doing is right, but do not see what other options could I try to make it work...

              Comment


              • #8
                Hey!

                If you have STS 2.9.2 installed, I would recommend to start with a Spring MVC template project and go from there. It contains everything you need to get started with a Spring MVC project, uses Maven under the hood, and you can drag&drop this right away on tc Server. And you mean the TC server from SpringSource/VMware, that comes with STS, right?

                Did you maybe also take a look at these links here:
                http://forum.springsource.org/showth...etting-Started

                HTH,
                -Martin

                Comment

                Working...
                X