Announcement Announcement Module
Collapse
No announcement yet.
Weblogic Deployment issue from STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Weblogic Deployment issue from STS

    Hello everyone,

    I'm going to start a new project where I'm going to use SpringFramework / Maven / WebLogic as app server, etc. Anyway, I did a little research because this is the first time I'm working with WebLogic server, I realized there is a plugin from oracle to be used in STS in order to deploy an application. Then, I downloaded it and it is working fine.

    Next step was try to run the application, and here my troubles begin

    The point is: when I deploy the application it is done without any issue. But when I run the app in the browser it fails due to it cannot find the welcome file list at the beginning (my index.jsp), after that it fails because it does not recognize the taglibs entries. This was really weird because I tried it before under tomcat without any problem.

    For that reason, in order to be sure I copied the war file manually to WebLogic, it means to user_projects/domains/my_domain/autodeploy, it was detected by WebLogic and it was deployed successfully. And what happened? It works!
    I don't know if the Weblogic plugin is looking for an EAR file or something like that, I've tried different ways suggested in order to deploy it from maven but I could not get it works. The examples I tried are complicated and fail in some steps explained so it became a problem for me. I mean, I could not find out the way to solve it. That's why I'm looking for your help.

    I hope it helps your understanding.

    Thanks in advance,

    Luis.
    Last edited by luisb; Aug 1st, 2012, 08:18 PM.

  • #2
    Hey Luis!

    Unfortunately I have no idea why that doesn't work with the plugin for the WebLogic server - and I am not using that server or that plugin myself, so never came across this situation or problem. Maybe someone else in this forum has an idea what is going on? Did you check maybe the preferences for that project (the deployment section maybe)? But that is just a wild guess...

    Another option might be to ask the folks who implemented the WebLogic plugin as well...

    Sorry for not being more helpful here...
    -Martin

    Comment

    Working...
    X