Announcement Announcement Module
Collapse
No announcement yet.
Problem with new STS 2.9.2 installation Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with new STS 2.9.2 installation

    Hi,

    I'm newby with Spring and I have some problems with STS 2.9.2.

    I have installed STS (using springsource-tool-suite-2.9.2.RELEASE-e3.7.2-linux-gtk-x86_64-installer.sh) on my Fedora 17 (3.4.6-2.fc17.x86_64) and Java 1.7 SE JDK [ Java(TM) SE Runtime Environment (build 1.7.0_05-b06), Java HotSpot(TM) 64-Bit Server VM (build 23.1-b03, mixed mode) ].

    Hardly had I run STS when I got [Fatal Error] :1:1: Premature end of file..
    I ignored it and created the simplest Java HelloWorld project. Then I got the following errors:
    Code:
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/internal/ui/refactoring/PushInRefactoringAction.java::0 class 'org.eclipse.ajdt.internal.ui.refactoring.PushInRefactoringAction' is already woven and has not been built in reweavable mode
    [org.eclipse.contribution.weaving.jdt] error at org/eclipse/contribution/jdt/cuprovider/CompilationUnitProviderAspect.aj::0 class 'org.eclipse.contribution.jdt.cuprovider.CompilationUnitProviderAspect' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.core] error at org/eclipse/ajdt/core/codeconversion/AJSourceIndexerRequestor.java::0 class 'org.eclipse.ajdt.core.codeconversion.AJSourceIndexerRequestor' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/internal/ui/editor/AdviceActionDelegate.java::0 class 'org.eclipse.ajdt.internal.ui.editor.AdviceActionDelegate' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/internal/ui/refactoring/pullout/PullOutRefactoringAction.java::0 class 'org.eclipse.ajdt.internal.ui.refactoring.pullout.PullOutRefactoringAction' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/internal/ui/refactoring/pullout/PullOutRefactoring.java::0 class 'org.eclipse.ajdt.internal.ui.refactoring.pullout.PullOutRefactoring' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.core] error at org/eclipse/ajdt/core/javaelements/AspectElement.java::0 class 'org.eclipse.ajdt.core.javaelements.AspectElement' is already woven and has not been built in reweavable mode
    [org.eclipse.contribution.weaving.jdt] error at org/eclipse/contribution/jdt/itdawareness/ITDAwarenessAspect.aj::0 class 'org.eclipse.contribution.jdt.itdawareness.ITDAwarenessAspect' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/ui/AJDTNameEnvironmentProvider.java::0 class 'org.eclipse.ajdt.ui.AJDTNameEnvironmentProvider' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.core] error at org/eclipse/ajdt/core/codeconversion/ITDAwareNameEnvironment.java::0 class 'org.eclipse.ajdt.core.codeconversion.ITDAwareNameEnvironment' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/internal/ui/refactoring/SelectionUtil.java::0 class 'org.eclipse.ajdt.internal.ui.refactoring.SelectionUtil' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/internal/ui/editor/quickfix/QuickFixProcessor.java::0 class 'org.eclipse.ajdt.internal.ui.editor.quickfix.QuickFixProcessor' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.ui] error at org/eclipse/ajdt/internal/launching/AspectJApplicationLaunchShortcut.java::0 class 'org.eclipse.ajdt.internal.launching.AspectJApplicationLaunchShortcut' is already woven and has not been built in reweavable mode
    [org.eclipse.contribution.weaving.jdt] error at org/eclipse/contribution/jdt/itdawareness/MatchLocationManipulatorAspect.aj::0 class 'org.eclipse.contribution.jdt.itdawareness.MatchLocationManipulatorAspect' is already woven and has not been built in reweavable mode
    [org.eclipse.ajdt.core] error at org/eclipse/ajdt/internal/core/search/AJDTSearchProvider.java::0 class 'org.eclipse.ajdt.internal.core.search.AJDTSearchProvider' is already woven and has not been built in reweavable mode
    [org.eclipse.contribution.weaving.jdt] error at org/eclipse/contribution/jdt/itdawareness/SearchHooksAspect.aj::0 class 'org.eclipse.contribution.jdt.itdawareness.SearchHooksAspect' is already woven and has not been built in reweavable mode
    Does anyone know what's wrong with my installation and how to cope with it?

    I tried all the above with previous version 2.9.1, but I got the same results.

    Thanks in advance

    Adam

    P.S. Today I tested both versions of STS 2.9.1 & 2.9.2 on Java SE 1.6.0_33, but I keep on getting errors.
    Errors thrown by STS 2.9.1 are enclosed in attached file.

    Does someone know what I do wrong?
    Do I need Java EE instead of SE?
    Last edited by Aquagen; Aug 1st, 2012, 10:02 AM. Reason: I checked STS 2.9.1 & 2.9.2 on Java 1.6.0_33

  • #2
    Hey Adam!

    The "premature end of file" is an error that we are seeing as well from time to time and we haven't found out yet what exactly is causing this error. But it doesn't seem to cause any problems, so I think you can safely ignore it.

    The other messages that you see on the console, reported from AJDT, are not really errors, as far as I know. They just indicate that the load-time weaving tries to weave a class that is already woven and therefore continues to use that already woven class. That should be fine as well. But I agree that we should try to improve those messages in order to not irritate people who might see them.

    So I think you can safely go ahead and use STS... :-)

    Cheers,
    -Martin

    Comment


    • #3
      Ok, thanks.
      I was worried if the project will collapse because of all this errors (on Fedora 16 I has no such problems).

      Comment

      Working...
      X