Announcement Announcement Module
Collapse
No announcement yet.
Query regarding STS and maven integration Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Query regarding STS and maven integration

    Hi,
    I have recently begun to use STS 2.9.2 in a Win7 environment and have a question regarding Maven integration.
    When I right-click on my pom.xml and select "Maven Build..." I then click on the "Select" button next to the Goals
    text box in the run configuration dialogue box. At this point a I expect to see a list of available goals. However
    all I see is a blank list box and a message stating "No entries available".

    Has anyone else come across this problem? Is there something else that needs to be configured to enable a list
    for use in the run configurations dialogue? I have alos seen this using Eclipse Indigo, Juno and THE JBoss Tools package.

    Cheers

  • #2
    Yes,

    I always set the goals manually at this point but looks like you need to enable Full index for the repositories in the Maven repositories view then rebuild the indexes in order to populate this thing (Rebuilding indexes can take time).

    Comment


    • #3
      Thanks NicoTexas. I tried reindexing the indeces but there was no difference: the dialogue list is empty.

      As noted above, I've tried this in a few Eclipse environments and it's the same result everytime. I'm tempted to raise this as a bug with the developers.

      Thanks again.

      Comment


      • #4
        Just tried and it works.
        Are you sure "Full index" is enabled ?

        Comment


        • #5
          Just double checked both the local and global repositories and it's enabled for both. Thanks for checking this out.
          I'm at a loss. Given it works for you and I've tried at least 4 installations I suspect it's something else I've missed?

          Comment


          • #6
            Hey!

            Can you maybe attach a sample project that illustrates the problem that you have?

            -Martin

            Comment


            • #7
              Hi Martin - thanks for replying.

              I've attached a very simple project to this post. It's just a plain old Hello World app based on the quickstart archetype. I obviously don't need some of the more esoteric goals for this one necessarily it's just that they're not there when I try and acess them fro mthe Run as ... dialogue.

              Thanks

              Comment


              • #8
                I believe the problem is related to m2e not getting the goals list and it's not related to any particular project configuration.
                The method I described is a workaround to this bug :
                https://bugs.eclipse.org/bugs/show_bug.cgi?id=344997

                Comment


                • #9
                  Thanks for the link to the Eclipse bug, seems to be that case.
                  Thanks for pointing that out!!!

                  -Martin

                  Comment


                  • #10
                    Thanks folks. The lack of selectable goals certainly isn't a "stopper" but it would be nice! I look forwad to ir reappearing in the future.
                    cheers

                    Comment

                    Working...
                    X