Announcement Announcement Module
Collapse
No announcement yet.
STS 2.9.2 display not updating on Linux in Javascript mode Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.9.2 display not updating on Linux in Javascript mode

    Hello,
    I downloaded STS 2.9.2 yesterday. Today, when playing with it, I noticed that when I double-clicked on the tab for the file, the display did expand, but many parts of the screen were not updated at all. In the image, several places that either blank that shouldn't be, and other parts that appear to have controls where I should be seeing my program.

    Thanks,

    Harlan...

  • #2
    I am using Ubuntu myself and haven't seen that problem. That being said I am still sticking with version 10.04 LTS for as long as it is supported. (Unfortunately, not much longer :-)

    I wouldn't be surprised to have to experience some 'growing pains' as both fairly big changes are afoot in both Eclipse 4.2 and Ubuntu w.r.t. UI widgetry. The Eclipse 4.x UI backend has been substantially reorganized since Eclipse 3.x and most people would probably agree it isn't quite "there yet" compared to the polish and reliablity of the 3.7 UI.

    At the same time Ubuntu moving to Unity and away from Gnome 2 is posing similar challenges w.r.t reliability of Eclipse's SWT implementation.

    Of course these problems do affect our users, but ultimately these are not problems/bugs in STS itself. As they are problems with the Eclipse SWT implementation and how it works on the newer Ubuntu UI.

    If you have the patience for it, the best thing to do is probably search the Eclipse bugzilla database, and if you don't find problems similar to this documented already, raise a bug report.

    You are also welcome to raise a bug report against STS about this, and I can then help further to follow up with you to try to find or raise a corresponding bug ticket against Eclipse itself.

    Useful links:
    - Eclipse bugzilla for SWT component (most likely where the problem comes from): http://www.eclipse.org/swt/bugs.php
    - STS bug tracker: https://issuetracker.springsource.com/browse/STS

    Kris

    PS: Images posted to this forum get scaled down automatically, so I can't see much on your image. (But I can imagine the kind of painting / update problem that you are describing).

    Comment


    • #3
      Hi Kris,
      Thank You for the quick reply. I tried to do the same thing directly in Eclipse and it worked just fine.

      I'm running:
      - Ubuntu 11.04, all current updates
      - Gnome Version: 2.32.1 Build Date: 04/14/2011
      - Eclipse Version: 3.7.2 Build id: M20120208-0800

      I'm sorry about the image. I was hoping you would be able to enlarge it, but alas...

      If you still would like, I can open an STS ticket in the couple of days.

      Thanks again for your help.

      Harlan...

      Comment


      • #4
        Hi Harlan,

        Yes, if it is something that works in Eclipse but not STS it is certainly a good idea to raise a ticket.

        Even if the problem is not in STS itself, raising an STS ticket is a good starting point. Eclipse devs are generally not receptive to tickets unless you can reproduce problem with a plain Eclipse.

        Also, before raising a ticket, it is useful to try out a more recent milestone of STS 3.0 based on Eclipse 4.2. Active development now is on 3.0.x based on E4.2 so it is most interesting to know about and fix problems with 3.0.

        You can get access to the milestone builds via the official STS downloads page
        http://www.springsource.org/downloads/sts

        Click on 'other downloads' to expand the 'hidden stuff' :-)
        Then scroll down to find 3.0.0.M3 based on E42.

        If you rather wait a little longer, 3.0.0 is in the final RC stages now and will be released shortly (sorry no precise date, maybe a week or so :-).

        Kris
        Last edited by Kris De Volder; Aug 1st, 2012, 01:37 PM. Reason: Remove a comment that clearly does not apply to the situation.

        Comment


        • #5
          Hi Kris,
          I downloaded Eclipse (Version: 4.2.0 Build id: I20120608-1400) tonight. I installed the Eclipse Web Development Platform and Javascript plugins; I tried to get the same ones that are install in STS 2.9.2. It worked just fine.

          Thanks again for your help!

          Harlan...

          Comment


          • #6
            Hi Kris,
            I finally got a chance to test STS 3.0.0 E4 tonight. It seems to be working just fine. I tried expanding/contracting several tabs, not just a code tab. While the expanding and contracting were noticeably slow, they did work.

            Thank You again for help. Please close this ticket.

            Have a Great Day!!!

            Harlan...

            Comment


            • #7
              Thanks for letting us know it works now.

              cheers,

              Kris

              Comment

              Working...
              X