Announcement Announcement Module
Collapse
No announcement yet.
STS 3.0.0 M1 and JDK 1.8 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.0.0 M1 and JDK 1.8

    Hello,

    I just upgraded to STS 3.0 and JDK 1.8 and having trouble running my builds with Ant.

    I am getting exception class not found Javac1.8

    Not sure what is the issue here. Read somewhere that Ant 1.8.3 is the issue. So is it that I won't be able to use JDK 1.8 until the next version of Ant is released?

    Also, is there a way to run different versions of JRE / JDK in parallel so that some applications can still use different versions? But my system version automatically gets updated to the latest version and am not able to change it.

    Please help me out.

    Thanks & Regards
    Surya

  • #2
    Hey Surya!

    I have no specific information about an incompatibility between JDK 1.8 and Ant, but since JDK 1.8 is not yet released, it could also be a problem with the latest JDK 1.8 builds that you seem to run.

    In general you are able to install several different versions of the JDK in parallel and switch between them. Just install the JDKs in separate locations and use the preferences in Eclipse/STS, for example, to use a specific JDK when you launch your app from within Eclipse/STS. There is a preference called "Installed JREs" where you can configure the available JDKs and then use them from within Eclipse/STS.

    HTH,
    Martin

    Comment

    Working...
    X