Announcement Announcement Module
Collapse
No announcement yet.
How to integrate Maven scm svn connector? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to integrate Maven scm svn connector?

    Hi,All
    I want to check out maven project from my svn repository.But I try many ways i got from internet,all fail.
    I update all plugins subeclipse,maven,sts and so on.When i use import with 'Check out Maven Projects from scm' wizard to download to download svn connector from m2eclipse marketplace,just get Attachment
    Attached Files

  • #2
    Hey!

    Can you post the content of that error window here? The attached screenshot got downscaled to much when posting here.
    Also what version of STS are you using?

    -Martin

    Comment


    • #3
      Originally posted by Martin Lippert View Post
      Hey!

      Can you post the content of that error window here? The attached screenshot got downscaled to much when posting here.
      Also what version of STS are you using?

      -Martin
      My STS Version:
      SpringSource Tool Suite

      Version: 2.9.2.RELEASE
      Build Id: 201205071000

      Another question,I use svn to host my maven projects,What scm plugin i need to install?There are many plugins for maven scm on m2e marketplace,thanks

      -janwen

      Comment


      • #4
        Hey Janwen!

        Don't see the content of the error dialog... Did you forget to post? ;-)

        I don't use Maven together with SVN, so I am not the best person to give advice in this case, but maybe other people on this forum use that combination?

        Cheers,
        -Martin

        Comment


        • #5
          Sorry for my late reply:
          Following is the content of the error dialog cap:
          Operation details
          Cannot complete the install because one or more required items could not be found.
          Software being installed: Maven SCM handler for Subclipse 0.13.0.201107071330 (org.sonatype.m2e.subclipse.feature.feature.group 0.13.0.201107071330)
          Missing requirement: Maven SCM Handler for Subclipse 0.13.0.201107071330 (org.sonatype.m2e.subclipse 0.13.0.201107071330) requires 'bundle org.tigris.subversion.subclipse.core [1.6.0,1.7.0)' but it could not be found
          Cannot satisfy dependency:
          From: Maven SCM handler for Subclipse 0.13.0.201107071330 (org.sonatype.m2e.subclipse.feature.feature.group 0.13.0.201107071330)
          To: org.sonatype.m2e.subclipse [0.13.0.201107071330]

          Comment


          • #6
            Hey!

            This error message looks like there is a missing dependency. Do you have Subclipse installed? And can you check whether you have a plugin "org.tigris.subversion.subclipse.core" in your plugins folder with a versio 1.6.x? If not, that seems to be the problem. I don't know exactly why the component you are trying to install requires that plugin with that version, but maybe the guys who implemented this "Maven SCM handler for Subclipse" know more details?

            HTH,
            Martin

            Comment


            • #7
              thanks,Martin,I give it up.waste a lot of my time.But i think STS should improve m2eclipse feature.

              Comment


              • #8
                Hey!

                What exactly do you mean by "STS should improve m2eclipse feature"? Functionality? Installation? Since this is "just" a third-party plugin that we incorporate, the room for improvement is somewhat limited, but I would be very interested to hear what you exactly mean and would wish to see.

                Thanks for your feedback!
                -Martin

                Comment


                • #9
                  Yeah,I just mean to improve the m2eclipse Installation and subeclipse related plugin Installation like m2eclipse connectors and so on.Thanks

                  Comment

                  Working...
                  X