Announcement Announcement Module
Collapse
No announcement yet.
Eclipse plug-in installation problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eclipse plug-in installation problem

    Hi,
    I'm having problems trying to installing the sts eclipse plugin. I tried to install it from both marketplace and following the installation guide downloaded from the sts website!
    I'm using eclipse Indigo JEE SR2 64 bit on a 64 bit linux system...the sts version is the 2.9.2.
    I've already installed sts successfully in another pc...the difference is the 32bit version of system and eclipse both.
    I have no real installation problem as it finishes successfully but when I restart eclipse no plugins are loaded at all.
    I mean are not loaded even m2e,egit,hibernate tools ecc..
    I tried to install first sts as I thought that sts plugin maybe has conflicts with another plugin but the results is the same...eclipse indigo is unable to load the plugin even if it is installed successfully!
    please..help...

  • #2
    So, the install is successful, but you don't see the new features inside of STS? Odd.

    Try the following:

    1. Make sure that the current user has write access to the STS install directory before installing STS.
    2. Take a look at the error log and post any relevant errors here: Window -> Show view -> Other -> Error log.
    3. Open the Plugin Registry view. Window -> Show view -> Other -> Plugin Registry. Look for the com.springsource.sts.ui bundle. Select, right-click -> show advanced, right-click -> Start (if it's not already started). Any exceptions?

    Comment


    • #3
      Hi...thanks for your reply.
      I solved creating a new eclipse installation in my home folder because I thought the problem was, as you correctly suggested, about eclipse folder permissions. I tried to modify them before posting this thread unsuccessfully as my first thought was just this one. Basically I was trying to install STS as eclipse plugin but my eclipse folder was located in my /opt folder. What happened is strange because in the other pc I hadn't any problem with this location even without changing folder permissions but with the bit version's difference. In fact the other pc has 32 bit eclipse/system version both.
      Is my problem related to the 64 bit eclipse/system write permission?!
      As I said before, at the moment I solved my problem with a new eclipse installation, always 64 bit version, but is interesting for me to know why I was unable to use it in my old way.
      btw...thanks again for your interest...

      Comment

      Working...
      X