Announcement Announcement Module
Collapse
No announcement yet.
sts 2.9.2 installation problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • sts 2.9.2 installation problem

    hi, i am new in spring. when i double click on .exe file of sts, it shows an error box. which says, 'error:java.lang.reflect.InvocationTargetException '. what should i do.

    N.B: No eclipse ide or netbeans is running on my PC when i trying to install sts 2.9.2

  • #2
    Hey!

    Do you see anything more in this error message? And on what system are you running? And what JDK version do you have installed? And do you mean the .exe file of the installer or the exe file of STS itself after a successful installation?

    -Martin

    Comment


    • #3
      Installing Springsource Tool Suite for the first time and it fails with the following message:

      ---------------------------
      Installer - SpringSource Tool Suite
      ---------------------------
      This application requires a Java Runtime Environment 1.5.0
      ---------------------------
      OK
      ---------------------------

      I am running on a 64-bit Windows platform. I downloaded this installer: springsource-tool-suite-2.9.2.RELEASE-e3.7.2-win32-x86_64-installer

      I have Java EE Installed:
      C:\Users\lyonsher\Desktop\Tools\GTM Tools>java -version
      java version "1.6.0_31"
      Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
      Java HotSpot(TM) 64-Bit Server VM (build 20.6-b01, mixed mode)

      Eclipse is installed: Eclipse Java EE IDE for Web Developers.
      Version: Indigo Service Release 2
      Build id: 20120216-1857

      And Maven 3.0.4

      Also the JAVA_HOME environment variable points to: C:\glassfish3\jdk

      Any ideas what I'm missing and why it wants an older JRE?

      Comment


      • #4
        Hey!

        Looks like everything is in place and should work. As a workaround, you can download the zipped version of STS 2.9.2 and just extract that. It doesn't give you the option to not install tc Server etc., but you should be ready to start STS after extracting the ZIP.

        HTH,
        Martin

        Comment


        • #5
          The zip file worked

          Originally posted by Martin Lippert View Post
          Hey!

          Looks like everything is in place and should work. As a workaround, you can download the zipped version of STS 2.9.2 and just extract that. It doesn't give you the option to not install tc Server etc., but you should be ready to start STS after extracting the ZIP.

          HTH,
          Martin
          That did work, and thanks. It'd be nice if the installer worked, but I'm okay with this at least.

          Comment

          Working...
          X