Announcement Announcement Module
Collapse
No announcement yet.
Problems with internet activity in STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with internet activity in STS

    I'm new to Java and STS, so it's likely I'm doing something dumb. I've been trying to work with STS for a couple days to create a new Spring MVC Template project. Whenever I try to use a Spring Template Project and then choose Spring MVC, it hangs when it tries to download the template. I tried a workaround I saw somewhere saying that when it fails to exit STS, and manually copy the file and update an XML file to say it's stored locally. And that worked - allowing me to create a project, but when I try to run the default project it fails because it doesn't have a dependency.

    This has me wondering if the problem of not being able to connect and get the template could be affecting me in other ways - that it can't get dependencies perhaps as well?

    Another example is when I go into STS to Help - Check for Updates and it slowly gets up to 50% and then hangs. I finally get this error:

    Some sites could not be found. See the error log for more detail.
    Unable to connect to repository http://dist.springsource.com/release....7/content.xml
    Connection timed out: connect
    Unable to connect to repository http://download.eclipse.org/releases/indigo/content.xml
    Connection timed out: connect

    Is there something I need to do to allow Eclipse to connect to the internet? I've tried downloading the current version as well as the 3 milestone release and the previous version and it's doing the same thing in all of them.
    Last edited by especht; Jun 12th, 2012, 01:35 PM.

  • #2
    Solved! I tried two things on this page: http://stackoverflow.com/questions/7...-to-repository - deleting the cache and then adding -Djava.net.preferIPv4Stack = true to the sts.ini file. It's working great now.

    Comment


    • #3
      Hey!

      Glad to hear you got it working and thanks for sharing the solution with us here!!!

      Cheers,
      -Martin

      Comment

      Working...
      X