Announcement Announcement Module
Collapse
No announcement yet.
Conflicting dependency during upgrade to 2.9.2 in Eclipse 3.6 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Conflicting dependency during upgrade to 2.9.2 in Eclipse 3.6

    I have pretty old version of the STS tools installed in eclipse (version 2.5.1). I've tried to update eclipse. Selected only main helios update site and required STS update sites
    http://download.eclipse.org/releases/helios
    http://dist.springsource.com/release/TOOLS/update/e3.6
    http://dist.springsource.com/release...composite/e3.6

    After check for update following problem:
    Cannot complete the install because of a conflicting dependency.
    Software being installed: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE)
    Software currently installed: SpringSource Tool Suite dm Server Tools 2.5.1.201011111000-RELEASE (com.springsource.sts.server.dm.feature.group 2.5.1.201011111000-RELEASE)
    Only one of the following can be installed at once:
    SpringSource Tool Suite OSGi runtime support 2.5.1.201011111000-RELEASE (com.springsource.sts.ide.osgi 2.5.1.201011111000-RELEASE)
    SpringSource Tool Suite OSGi Runtime Support 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.osgi 2.9.2.201205071000-RELEASE)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.5.1.201011111000-RELEASE (com.springsource.sts.feature.group 2.5.1.201011111000-RELEASE)
    To: com.springsource.sts.ide.osgi [2.5.1.201011111000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE)
    To: com.springsource.sts.ide.osgi [2.9.2.201205071000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite dm Server Tools 2.5.1.201011111000-RELEASE (com.springsource.sts.server.dm.feature.group 2.5.1.201011111000-RELEASE)
    To: com.springsource.sts.feature.group [2.5.1,2.6.0)


    It doesn't matter what modules are selected for update (i've selected all), error message could be on different modules but same reason , for example like this:

    Cannot complete the install because of a conflicting dependency.
    Software being installed: SpringSource Tool Suite Tutorial Authoring 2.9.2.201205071000-RELEASE (com.springsource.sts.authoring.feature.group 2.9.2.201205071000-RELEASE)
    Software currently installed: SpringSource Tool Suite dm Server Tools 2.5.1.201011111000-RELEASE (com.springsource.sts.server.dm.feature.group 2.5.1.201011111000-RELEASE)
    Only one of the following can be installed at once:
    SpringSource Tool Suite OSGi runtime support 2.5.1.201011111000-RELEASE (com.springsource.sts.ide.osgi 2.5.1.201011111000-RELEASE)
    SpringSource Tool Suite OSGi Runtime Support 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.osgi 2.9.2.201205071000-RELEASE)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Tutorial Authoring 2.9.2.201205071000-RELEASE (com.springsource.sts.authoring.feature.group 2.9.2.201205071000-RELEASE)
    To: com.springsource.sts.tutorials.feature.group [2.9.2,2.10.0)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.5.1.201011111000-RELEASE (com.springsource.sts.feature.group 2.5.1.201011111000-RELEASE)
    To: com.springsource.sts.ide.osgi [2.5.1.201011111000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE)
    To: com.springsource.sts.ide.osgi [2.9.2.201205071000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite dm Server Tools 2.5.1.201011111000-RELEASE (com.springsource.sts.server.dm.feature.group 2.5.1.201011111000-RELEASE)
    To: com.springsource.sts.feature.group [2.5.1,2.6.0)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Tutorials 2.9.2.201205071000-RELEASE (com.springsource.sts.tutorials.feature.group 2.9.2.201205071000-RELEASE)
    To: com.springsource.sts.feature.group [2.9.2,2.10.0)

  • #2
    Have you installed any other top-level features from the STS old 2.5.x update site (eg, OSGi runtime support or dm server tools)? If so, you should remove them first and try again. This might work.

    However, your best bet would be to start from scratch and download a new 2.9.2 based on indigo (Eclipse 3.7).

    Comment


    • #3
      Thanks, there was dm server tools installed. After remove them update went through.

      Comment


      • #4
        Glad to hear its working now!

        Cheers,
        -Martin

        Comment

        Working...
        X