Announcement Announcement Module
Collapse
No announcement yet.
Hibernate under Sprinsource conflict Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hibernate under Sprinsource conflict

    I've downloaded and installed:
    SpringSource Tool Suite
    Version: 2.9.2.RELEASE

    Which uses:
    Eclipse Platform
    Version: 3.7.2.

    I'm trying to install Hibernate with under the "Install new software.." from jboss - http://download.jboss.org/jbosstools/updates/stable/
    But I get this error message:
    Cannot complete the install because of a conflicting dependency.
    Software being installed: JBoss Maven Hibernate Configurator 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.hibernate.feature.feature.g roup 1.2.0.v20111027-1501-H240-Final)
    Software currently installed: Maven Integration for WTP 0.15.0.20120201-1300 (org.maven.ide.eclipse.wtp.feature.feature.group 0.15.0.20120201-1300)
    Only one of the following can be installed at once:
    Maven Integration for Eclipse WTP 0.13.1.20110718-1012 (org.maven.ide.eclipse.wtp 0.13.1.20110718-1012)
    Maven Integration for Eclipse WTP 0.15.0.20120201-1300 (org.maven.ide.eclipse.wtp 0.15.0.20120201-1300)
    Maven Integration for Eclipse WTP 0.13.0.20110623-0455 (org.maven.ide.eclipse.wtp 0.13.0.20110623-0455)
    Maven Integration for Eclipse WTP 0.13.1.20110728-1800 (org.maven.ide.eclipse.wtp 0.13.1.20110728-1800)
    Cannot satisfy dependency:
    From: JBoss Maven Core 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.core 1.2.0.v20111027-1501-H240-Final)
    To: bundle org.maven.ide.eclipse.wtp [0.13.0,0.15.0)
    Cannot satisfy dependency:
    From: JBoss Maven Hibernate Configurator 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.hibernate 1.2.0.v20111027-1501-H240-Final)
    To: bundle org.jboss.tools.maven.core 0.0.0
    Cannot satisfy dependency:
    From: JBoss Maven Hibernate Configurator 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.hibernate.feature.feature.g roup 1.2.0.v20111027-1501-H240-Final)
    To: org.jboss.tools.maven.hibernate [1.2.0.v20111027-1501-H240-Final]
    Cannot satisfy dependency:
    From: Maven Integration for WTP 0.15.0.20120201-1300 (org.maven.ide.eclipse.wtp.feature.feature.group 0.15.0.20120201-1300)
    To: org.maven.ide.eclipse.wtp [0.15.0.20120201-1300]

    Any thoughts how to resolve this ?

  • #2
    Hey!

    The update site you have mentioned is the stable Jboss tooling update site that is compatible with Eclipse Helios (3.6.2). If you are using STS 2.9.2, which is based on Eclipse 3.7.2, you should at least use the development version of the JBoss tools (they are compatible with Indigo: http://download.jboss.org/jbosstools...opment/indigo/ and install into STS 2.9.2).

    (If you don't want to use that Indigo-compatible version, you could also try to uninstall the Maven Integration for Eclipse WTP 0.15.0 - using the about dialog, installation details, and then uninstall that feature. After that, you should be able to install the older versions again, but I don't know if they require older Maven Eclipse integrations as well, so I would be very careful with that and strongly prefer to use the development version mentioned above).

    HTH,
    Martin

    Comment

    Working...
    X