Announcement Announcement Module
Collapse
No announcement yet.
Sts 2.9 no update and rebuild index repository maven Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sts 2.9 no update and rebuild index repository maven

    Hi,
    I've installed SpringSource Tool Suite Version: 2.9.2.RELEASE with pointer at jdk 1.5. The current release of STS include maven 3.x but I've the problem when interact with DEPENDENCIES and maven repository:
    1) In "Maven Repositories" View the Rebuild Index remains stationary at 0%.
    2) When Add Dependencies (es. junit) does not return anything.
    I tried with maven 2 but nothing!
    I recently went over to STS + maven!
    Help me
    P. S.: I am sorry for not perfect English

    Bye

  • #2
    Hey!

    Are you behind a firewall or corporate proxy maybe? If so, you need to configure Maven (settings.xml file in your .m2 folder) to use those proxies.

    HTH,
    Martin

    Comment


    • #3
      This is the error that occurs after the download reaches 20% or other percentage (but typically does not exceed 30%). I tried to disable windows firewall and glialtri, but nothing:

      eclipse.buildId=2.9.2.201205071000-RELEASE
      java.version=1.6.0_31
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=it_IT
      Framework arguments: -product com.springsource.sts.ide
      Command-line arguments: -os win32 -ws win32 -arch x86 -product com.springsource.sts.ide

      Error
      Mon Jun 04 20:16:41 CEST 2012
      Unable to update index for central|http://repo1.maven.org/maven2

      Comment


      • #4
        Hey!

        Usually those problems are related to proxies or internet connection problems (or both). Does Maven work when you execute something from the command line? Do you have the correct connection settings in your Maven settings.xml file and Eclipse/STS configured to use that file (from the preferences)? That is all that comes to my mind at the moment... Sorry for not being more helpful here...

        -Martin

        Comment


        • #5
          I solved the problem on Windows 7 machine a few days ago so trivial
          In ... apache-maven-3.0.3 \ conf dir you have settings.xml.
          - Uncomment the tag <proxies>
          - Edit as follows:
          <proxy>
          <id> optional </ id>
          <active> true </ active>
          <protocol> http </ protocol>
          <host> </ host>
          <port> </ port>
          <username> </ username>
          <password> </ password>
          <nonProxyHosts> </ nonProxyHosts>
          </ Proxy>
          </ proxies>
          This in the case where it is desired to make changes to all users who use the same source. In case you want to edit the configuration file in the user repository, then you must make this same change in the settings.xml local repository (./m2).

          Thanks for everything.

          regards,
          Gianluigi

          Comment


          • #6
            Hey Gianluigi!

            Glad to hear you got it working and thanks for sharing the solution with us here!!!

            Cheers,
            -Martin

            Comment

            Working...
            X