Announcement Announcement Module
Collapse
No announcement yet.
Cannot update Grails Support from 2.9.1 to 2.9.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot update Grails Support from 2.9.1 to 2.9.2

    Hi.

    I had installed SpringSource Tool Suite 2.9.1 with Grails Support and now I've tried to update it from the application, but I'm getting the following error:

    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Grails Support 2.9.2.201205071000-RELEASE (com.springsource.sts.grails.feature.group 2.9.2.201205071000-RELEASE)
    Missing requirement: SpringSource Tool Suite Configuration Flow Editing 2.9.2.201205071000-RELEASE (com.springsource.sts.config.flow 2.9.2.201205071000-RELEASE) requires 'bundle org.eclipse.mylyn.commons.ui [3.7.0,4.0.0)' but it could not be found
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE)
    To: com.springsource.sts.config.flow [2.9.2.201205071000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Support 2.9.2.201205071000-RELEASE (com.springsource.sts.grails.feature.group 2.9.2.201205071000-RELEASE)
    To: com.springsource.sts.feature.group [2.9.2,2.10.0)
    What can I do?

    BTW: the registration form is just plain ridiculous. I've had to repeat it five times in order to properly write the captcha and the weirdo questions.

  • #2
    me too

    I have this issue as well.

    Comment


    • #4
      Hey!

      Originally posted by TheOm3ga View Post
      BTW: the registration form is just plain ridiculous. I've had to repeat it five times in order to properly write the captcha and the weirdo questions.
      What captcha do you mean? When I go to http://www.springsource.com/developer/sts and click on "Download STS", I don't see a captcha and I can by-pass the questions by agreeing to the license terms and select the "take me directly to the downloads" link. Do you use a different URL?

      -Martin

      Comment


      • #5
        Hey!

        Originally posted by [email protected] View Post
        I also found that adding THIS update site, resolved the grails upgrade issue in STS 2.9.2 that I had

        http://download.eclipse.org/mylyn/snapshots/weekly
        Yes, there seems to be a problem with the composite update site pointing to the wrong Mylyn version. I fixed this and it would work out-of-the-box again. Apologize for the inconvenience...

        -Martin

        Comment

        Working...
        X