Announcement Announcement Module
Collapse
No announcement yet.
grails dsl-support and plugin_dsld_support build path problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • grails dsl-support and plugin_dsld_support build path problems

    Hello,

    Sorry if this is something easy. I've search for a few hours and haven't found anything, but it's probably something obvious I'm missing.

    This has been happening to me consistently when creating a new grails project in STS.

    Every time I create a new grails project in STS, I end up with 2 Java Build Path Problems.

    The container 'Grails Dependencies' references non existing library 'C:\athockey\tools\sts-2.9.1.RELEASE\plugins\com.springsource.sts.grails. resources_2.9.1.201203221000-RELEASE\dsl-support\'

    The container 'Groovy DSL Support' references non existing library 'C:\athockey\tools\sts-2.9.1.RELEASE\plugins\org.codehaus.groovy_1.8.6.xx-20120301-1000-e37-RELEASE\plugin_dsld_support\'

    (see attached image)
    Attachment


    Java: 1.7.0_03 64-Bit
    OS: Windows 7 Home Premium
    STS/Grails-plugin: Version: 2.9.1.RELEASE - Build Id: 201203221000
    Grails: 2.0.3
    Groovy-Compiler: 1.8.6.xx-20120301-1000-e37-RELEASE
    Groovy-eclipse-plugin: Version: 2.6.1.xx-20120301-1000-e37-RELEASE


    What am I missing here?

    Thanks,

    -mike(n)
    Attached Files

  • #2
    Hi Mike,

    It looks like the folders do not exist. Have a look at your filesystem and see if these folders exist:
    'C:\athockey\tools\sts-2.9.1.RELEASE\plugins\com.springsource.sts.grails. resources_2.9.1.201203221000-RELEASE\dsl-support\'
    'C:\athockey\tools\sts-2.9.1.RELEASE\plugins\org.codehaus.groovy_1.8.6.xx-20120301-1000-e37-RELEASE\plugin_dsld_support\'

    There is a chance that you will see something like this instead:
    'C:\athockey\tools\sts-2.9.1.RELEASE\plugins\com.springsource.sts.grails. resources_2.9.1.201203221000-RELEASE.jar'
    'C:\athockey\tools\sts-2.9.1.RELEASE\plugins\org.codehaus.groovy_1.8.6.xx-20120301-1000-e37-RELEASE.jar'

    If this is the case, then your installation is incorrect. These bundles should be exploded (ie- unzipped) in your plugins folder. If this is the case, then you will need to reinstall. Regardless, it looks like something is wrong with your installation, so that would probably be a good thing to do anyway.

    Comment


    • #3
      Thanks for the insight, I'll check it out when I get home tonight.
      I do seem to remember that the directories did exist, but were empty. ...don't take that as gospel because it's been a few days now and I need to double check.

      My installation process was as follows.
      1. download/unzip sts (zip install, not exe)
      2. open sts, select grails and groovy estensions
      3. re-boot eclipse when installation is complete
      4. create new grails project


      You said, "there is a chance I'll see jar files" ...what case would that be?
      I repeated this installation process multiple times in as much of a clean-room style as I could and still had the same result. Is it possible the zip installation of sts has something to do with it?

      Comment


      • #4
        Originally posted by mnebus View Post
        You said, "there is a chance I'll see jar files" ...what case would that be?
        I repeated this installation process multiple times in as much of a clean-room style as I could and still had the same result. Is it possible the zip installation of sts has something to do with it?
        Sometimes people try to install by downloading a zip of the update site and copying the plugins and features into their Eclipse/STS installation. This won't work since the update site stores all of the plugins as jars, but they need to be exploded before they can be installed.

        I don't know how these directories could be empty since all the install process does is downloads the jar and extracts the contents to your install location.

        I have also seen situations where being behind a firewall causes some wackiness (but usually this corresponds to not being able to download at all).

        I have also seen situations where installing into a read-only location causes problems. But again, the problem tends to manifest differently. ie- not being able to run the patched JDT compiler.

        You could also try installing from the nightly update site:
        http://dist.springsource.com/snapsho...S/nightly/e3.7
        Add this to the work with section of Help -> Install new software... This may help, but only if the problem is with our update site (which is doubtful since no one else has reported this problem, but it may be worth a try).

        Comment


        • #5
          Dear Andrew,

          I got the same issue with Mike, and saw the following errors every time creating a new Grails project:

          The container 'Grails Dependencies' references non existing library 'D:\SWAT\ggts-3.0.0-64bit\springsource\ggts-3.0.0.RELEASE\plugins\org.grails.ide.eclipse.resou rces_3.0.0.201208091000-RELEASE\dsl-support\'

          The container 'Groovy DSL Support' references non existing library 'D:\SWAT\ggts-3.0.0-64bit\springsource\ggts-3.0.0.RELEASE\plugins\org.codehaus.groovy_1.8.6.xx-20120720-1100-e42\plugin_dsld_support\'

          I can make sure the above 2 directories exist, please also see the screenshot.

          I'm using the latest GGTS zip package, and then install the m2e plugin, detail as below:

          Groovy/Grails Tool Suite x86_64bit
          Version: 3.0.0.RELEASE
          Build Id: 201208091018

          Win7 64bit
          jvm C:/Program Files/Java/jdk1.6.0_25/bin/javaw.exe

          thanks for your attention

          regards,
          Bob

          Comment


          • #6
            Can you be more specific? Exactly which folder is missing? Is it org.codehaus.groovy_1.8.6.xx-20120720-1100-e42 or plugin_dsld_support?

            Do you have a org.codehaus.groovy_1.8.6.xx-20120720-1100-e42.jar file in the plugins folder? If yes, then this implies that groovy-eclipse is not installed properly and that you may have unzipped the update site instead of installed it through the update manager.

            Comment


            • #7
              Hi Andrew,

              thanks for your prompt reply, actually both folders are missing as per GGTS error logs, but in fact these 2 folders are right there on my disk.

              I also checked there's no org.codehaus.groovy_1.8.6.xx-20120720-1100-e42.jar nor org.grails.ide.eclipse.resources_3.0.0.20120809100 0-RELEASE.jar under plugins folders.

              I downloaded GGTS zip package and then unzipped it, and I installed only M2E in dashboard/extensions, without installing any other plugins / extensions.

              Is there any other clues? Thanks in advance.

              regards,

              Bob

              Comment


              • #8
                Just to be clear, do you see the plugins/org.codehaus.groovy_1.8.6.xx-20120720-1100-e42 and plugins/org.grails.ide.eclipse.resources_3.0.0.20120809100 0-RELEASE folders in your ggts installation?

                If you are using the GGTS zip, then they should be there, but just trying to make sure since this is what the error you are getting is saying.

                Another possibility is that there is an error earlier on in your startup that indirectly caused this problem. Can you attach the entire .log file from your workspace/.metadata folder?

                Comment


                • #9
                  Hi Andrew,

                  the above two folders are right there on my disk, with the urls as below:

                  D:\SWAT\ggts-3.0.0-64bit\springsource\ggts-3.0.0.RELEASE\plugins\org.grails.ide.eclipse.resou rces_3.0.0.201208091000-RELEASE\dsl-support

                  D:\SWAT\ggts-3.0.0-64bit\springsource\ggts-3.0.0.RELEASE\plugins\org.codehaus.groovy_1.8.6.xx-20120720-1100-e42\plugin_dsld_support\

                  I'm also attaching the .log file in zip below, kindly please check it out, thanks a lot!

                  regards,
                  Bob

                  Comment


                  • #10
                    Hi,

                    any idea on this? Thanks again.

                    regards,
                    Bob

                    Comment


                    • #11
                      Thanks for the log file. It looks to me that something is fishy when upgrading your old 2.x workspace to 3.x. You can try the following things to fix:

                      1. restart with the -clean option (run STS from the command line and include the -clean flag)
                      2. delete the .metadata folder in your workspace folder and restart. You will need to re-import all the old projects. (actually, don't delete, just move the .metadata folder to somewhere else in case you want it for some reasons). If you have tweaked your settings, and want to save them, you can go file -> export -> settings and then re-import them after creating the new workspace.

                      Apologies, I'm on vacation right now, so don't have much access to email.

                      Comment


                      • #12
                        Guys, were you able to resolve this issue? I am having the same one...

                        Comment


                        • #13
                          Here are the details of the error I get:
                          11:14:22.003 ERROR - Invalid value of sonar.libraries for com.otpp.email:bulkemail-downloader
                          Exception in thread "main" org.sonar.runner.impl.RunnerException: Unable to execute Sonar
                          at org.sonar.runner.impl.BatchLauncher$1.delegateExec ution(BatchLauncher.java:91)
                          at org.sonar.runner.impl.BatchLauncher$1.run(BatchLau ncher.java:75)
                          at java.security.AccessController.doPrivileged(Native Method)
                          at org.sonar.runner.impl.BatchLauncher.doExecute(Batc hLauncher.java:69)
                          at org.sonar.runner.impl.BatchLauncher.execute(BatchL auncher.java:50)
                          at org.sonar.runner.impl.BatchLauncherMain.execute(Ba tchLauncherMain.java:41)
                          at org.sonar.runner.impl.BatchLauncherMain.main(Batch LauncherMain.java:59)
                          Caused by: java.lang.IllegalStateException: No files nor directories matching 'C:\Program Files\springsource\ggts-3.4.0.RELEASE\plugins\org.codehaus.groovy_2.0.7.xx-20130828-1400-e43-RELEASE\plugin_dsld_support\' in directory C:\Users\SHEVELD\workspace\bulkEmailDownloader
                          at org.sonar.batch.scan.DefaultProjectBootstrapper.va lidateDirectories(DefaultProjectBootstrapper.java: 343)

                          I posted my question on StackOverflow, but no luck thus far:
                          http://stackoverflow.com/questions/2...-eclipse-issue

                          Comment


                          • #14
                            Sorry I can't tell you how/if the people in this thread before have solved the problem. They are no longer around. This is an old thread.

                            So I can only give some more hints on what you can try.

                            Besides the hints already given above there is one extra thing that jumps out to me here for your case:

                            It looks like you installed GGTS under 'C:\Program Files'. We have had reports in the past that this can cause problems because this folder is 'special' on Windows system and enforces certain kinds of unusual read/write limitations on the contents in this folder. This has been causing problems with GGTS and Greclipse installations in the past.

                            I would suggest you try and reinstall GGTS and choose a different 'not special' folder. For example 'C:\ggts'. It is also a good idea to avoid paths with spaces in them. In an ideal world spaces in the path should make no difference but in reality spaces often trigger bugs because some code inadvertently interprets the spaces as separators.

                            Kris

                            Comment


                            • #15
                              Thank you Kris,
                              Installing GGTS 3.5 in C:\Tools (outside the Program Files folder) has resolved the immediate issue.

                              Comment

                              Working...
                              X