Announcement Announcement Module
Collapse
No announcement yet.
Problem installing extensions for STS 2.9.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem installing extensions for STS 2.9.1

    I'm trying to install STS 2.9.1 Grails support and Groovy Eclipse extension but I'm getting a notification:

    The following connectors are not available: Grails Support

    Proceed with the installation anyways?

    What's up with this?

    I dont know if its relevant but I have java 1.7u4 and I've manualy installed Grails 1.3.7. I have Windows 7 64bit and installing STS 64bit.

    I've tried to install STS 2.8.1 but it's the same.

    It's extremely frustrating so please help.

  • #2
    This is mostly likely related to what you are seeing:
    http://forum.springsource.org/showth...Grails-Support

    I am not sure why you are seeing it now. But, you could try avoiding the extension page and installing from the install manager. Go to: Help -> Install new software. In the work with box, choose http://dist.codehaus.org/groovy/dist...snapshot/e3.7/ (you will need to add it if it isn't already there).

    Check the required groovy-eclipse pieces and follow the steps to install (no need to restart).

    Then do the same for this update site http://dist.springsource.com/release/TOOLS/update/e3.7

    And choose Grails Support. This time restart after installing.

    This should fix your problem.

    Comment


    • #3
      Hi,
      I had the same problem with the Google Plugin and this solution solved also my problem.

      Comment

      Working...
      X