Announcement Announcement Module
Collapse
No announcement yet.
Grails will not run Grails application Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grails will not run Grails application

    I keep seeing a "[project name] does not appear to be part of a Grails application"

    Envirnonment: Ubuntu 11.10, STS 2.9.1, Grails 2.0.3

    Downloaded a medium sized project from github, imported, refreshed, checked dependencies, and tried to run.

    Attempted fixes:
    ran grails upgrade. Same result
    ran grails clean. Same result
    quit STS, started again, refreshed dependencies. Same result
    Folder structure matches legal grails folders, I believe. grails-app is in top level folder.

    Any suggestions? I have spent 3-4 hours on this with no result.

    Update: from what I can gather from Grails.org (http://grails.org/Checking+Projects+into+SVN) it sounds like 'grails upgrade' should recreate or reset all files so that grails recognizes a project.

    Update: oops, this really should be in the Grails forum. Should I repost or should a mod move it?
    Last edited by MikeTempleman; May 6th, 2012, 02:27 PM. Reason: fixed problem

  • #2
    Fixed.

    I opened a grails command line from within STS and executed a "run-app" command successfully, which indicated that the problem was in the workspace caches. So I nuked the workspace, reloaded the project, refreshed dependencies, and now everything is working.

    Comment


    • #3
      Hi Mike,

      I'm glad you were able to fix this problem. If you think the problem is caused by STS, and you think you can reproduce it. It may be worth raising a bug on the issue tracker (https://issuetracker.springsource.com/browse/STS). If we are able to figure out what caused the problem in the first place, we may be able to do something about it and save some other people a bunch of hassle in the future.

      Trying to reproduce and document the steps is some work on your behalf, so if you rather just not do that and get on with your actual work instead, I understand. So don't feel pressured :-)

      Cheers,

      Kris
      Last edited by Kris De Volder; May 7th, 2012, 02:22 PM. Reason: Added link to issue tracker

      Comment


      • #4
        Kris

        It happened again and the same workaround resolved the problem. I posted a bug on issuetracker.

        Comment

        Working...
        X