Announcement Announcement Module
Collapse
No announcement yet.
"Build path specifies execution environment JavaSE-1.6" message even though incorrect Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Build path specifies execution environment JavaSE-1.6" message even though incorrect

    Suddenly I see this under "Java Build Path problems" in "Markers" of my simple test project for Selenium integration tests shortly after when my single Webdriver test ran green:
    Build path specifies execution environment JavaSE-1.6. There are no JREs installed in the workspace that are strictly compatible with this environment.
    Yet my build path says J2SE-1.5, Project facets says 1.5, Compiler compliance level is 1.5, POM file states source and target is 1.5. So what's triggering this message?

    I do have openjdk1.7 listed as my JavaSE-1.6 environment and I have built several successful projects with it.

    Is it my workspace that have gone haywire? I wish I knew more about how to protect it and/or verify it.


    Springsource 2.8.1Release or 3.0.0Snapshot.

  • #2
    The faulty (?) message survived multiple builds, but now it's gone. I re-factored a file and added spring-test as a dependency. These don't seem likely to be behind making it go away.

    Comment


    • #3
      Hey!

      Just in case you are coming across this problem again: what happens if you remove the build path entry for your JRE lib and add that again via the "add variable...", selecting JRE library and selecting the JDK that you are using?

      HTH,
      Martin

      Comment

      Working...
      X