Announcement Announcement Module
Collapse
No announcement yet.
MVC project wizard (top-level package) not working 2.9.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • MVC project wizard (top-level package) not working 2.9.1

    I have installed STS 2.9.1 from marketplace in my Eclipse 3.7.2

    When I try to create a MVC project with wizard

    1. new Spring Template Project > Spring MVC project
    2. I enter project name OK
    3. But when I try to specify a top-level package :

    aa.bb.cc

    I get : Define project specific settings. Required settings are denoted by "*".

    aa.bb.cc.

    I get: Input for field topLevelPackage does not match the regex \w+\.\w+(\.\w+)+.

    aa.bb.cc*
    I get: Input for field topLevelPackage does not match the regex \w+\.\w+(\.\w+)+.

    What's failing?

  • #2
    Hey!

    I am confused why you are seeing this message. When you create a new project from the MVC template, you should just need to type in the project name and a three-level deep package structure, like you did with "aa.bb.cc". You don't need a "*" at the end or something like that.

    Maybe something is going wrong under the hood, so can you maybe take a look at the Error Log view to see if there is anything related to this showing up?

    Thanks,
    Martin

    Comment


    • #3
      Hey!

      btw: if you have installed STS from the Marketplace, please take care of installing the Maven Integration for Eclipse (m2e 1.0) as well, if you want to work with the MVC template project. It is based on Maven and would therefore not work without the m2e support in Eclipse.

      (its unrelated to the problem you described above, but I thought I mention in here)

      HTH,
      Martin

      Comment


      • #4
        great!
        I installed maven and now I can create the project.

        (there should be a warning in STS about this dependency)

        Thanks Martin.

        Comment


        • #5
          Hey!

          Glad to hear its working now. We will add a check to figure out whether the m2e support is installed or not in case the template needs it. This is planned for the next release (3.0).

          Cheers,
          -Martin

          Comment

          Working...
          X