Announcement Announcement Module
Collapse
No announcement yet.
Unable to Install Groovy-Eclipse Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Install Groovy-Eclipse

    Hi,
    I'm unable to install Groovy-Eclipse on Eclipse Indigo SR2 via Eclipse Marketplace. The error message was follows:

    Communication with repository at http://dist.springsource.org/release/GRECLIPSE/e3.7/ failed.
    Read timed out

  • #2
    Hey!

    This is usually the result of a proxy/network issue. Are you behind a proxy/firewall? If so, can you take a look at the Eclipse network settings and configure your proxy there (Preferences -> General -> Network Connections).

    HTH,
    Martin

    Comment


    • #3
      Hi,
      No, I'm doing this from my home, so there's no firewall involved. I also tried this with my anti-virus software disabled, but without any change.

      Comment


      • #4
        Are you able to connect to any update site, for example by going to the "Install New Software" dialog and select the Eclipse Indigo site? Do you see any content for that repo, for example?

        Comment


        • #5
          Hi,
          I'm able to access other update sites, both via Eclipse Marketplace, as well the "Install New Software" dialog. I was able to successfully install the "M2E" maven plugin shortly before this reply.

          Thanks,
          Debojit

          Comment


          • #6
            Try installing from this update site instead:

            http://dist.codehaus.org/groovy/dist...snapshot/e3.7/

            This will give you the snapshot version of groovy-eclipse.

            Comment


            • #7
              Hi,
              With link provided by Andrew, I'm getting the following error in Eclipse:

              Cannot complete the install because one or more required items could not be found.
              Software being installed: Groovy-Eclipse M2E integration pre v1.0 (deprecated) 1.0.0.201106101132 (org.codehaus.groovy.m2eclipse.feature.group 1.0.0.201106101132)

              Thanks,
              Debojit

              Comment


              • #8
                You are checking the box for the deprecated Groovy-Eclipse m2e integration. Uncheck that box and try again.

                Comment

                Working...
                X