Announcement Announcement Module
Collapse
No announcement yet.
Cannot get list of grails plugins ( 2.9.1 / Grails 2.0.3); and plugins won't install Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot get list of grails plugins ( 2.9.1 / Grails 2.0.3); and plugins won't install

    The list of available plugins is very short, and a refresh does not make any difference. I expect to see dozens but there are only the few provided with STS. I am not using a proxy so that's not the reason. Is there another setting I need to change somewhere?
    If I try to install the plugin manually that does not always work either, e.g.

    "install-plugin dojo" produces this response in the console:

    | Loading Grails 2.0.3
    | Configuring classpath.
    | Environment set to development.....
    | Resolving plugin dojo. Please wait...
    | Downloading: grails-dojo-1.7.2.0.zip
    | Error Plugin not found for name [dojo] and version [not specified]

    However "install-plugin yui" give me:

    | Loading Grails 2.0.3
    | Configuring classpath.
    | Environment set to development.....
    | Resolving plugin yui. Please wait...
    | Downloading: yui-2.8.2.1.pom
    | Downloading: grails-yui-2.8.2.1.zip.sha1
    | Installing zip yui-2.8.2.1.zip.....
    | Installed plugin yui-2.8.2.1.....
    | Plugin installed.

  • #2
    I just tried and the plugin seems to install ok for me.

    > The list of available plugins is very short, and a refresh does not make any difference.

    I have experienced this kind of thing in the past. Usually it means there are intermittent problems with the plugin list file(s) on grails.org (sometimes they get corrupted when someone uploads a new plugin version). It could be the problem is already fixed. Could you please try refreshing the list again and try again to install your plugin.

    If it still not working, let me know and we will dig a little deeper.

    Kris

    Comment


    • #3
      Originally posted by Kris De Volder View Post
      I just tried and the plugin seems to install ok for me.

      > The list of available plugins is very short, and a refresh does not make any difference.

      I have experienced this kind of thing in the past. Usually it means there are intermittent problems with the plugin list file(s) on grails.org (sometimes they get corrupted when someone uploads a new plugin version). It could be the problem is already fixed. Could you please try refreshing the list again and try again to install your plugin.

      If it still not working, let me know and we will dig a little deeper.

      Kris
      Hi, don't know if it's related but I had to change my grails installation to 1.3.8. It seems 2.0.3 does not work with the IBM JDK 6. And now everything works correctly!

      Comment


      • #4
        I've played with Grails 2.0.3 without issues with Java 6. This was the *Sun* Java 6 JDK though. If it is true that Grails 2.0.3 doesn't work with IMB Java 6, it may be worth bringing this to the attention of the Grails core developers by raising an issue on their issue tracker. (here: http://jira.grails.org/)

        Re the list plugins. It is possible there is a relation. But the problem you described sounded like the list of plugins was corrupted as I've encountered before. This is usually an intermittent problem, also I believe the lists is specific to each version of Grails, so just switching your version may seem to fix the problem.

        Kris

        Comment

        Working...
        X