Announcement Announcement Module
Collapse
No announcement yet.
Spring IDE for RAD 7.0.0.7 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring IDE for RAD 7.0.0.7

    Hi,
    In my current development environment, we are using IDE RAD version 7.0.0.7 for developing spring web application. As we utilise spring web flow and spring MVC, i would like to install spring ide plugin.

    I have seen many topics surrounding installing spring ide plugin on RAD including the link attached, but i seem to be prevented from installing.
    http://www.ibm.com/developerworks/wi....pdf?version=1


    As i am behind a proxy, i have downloaded the update site; springsource-tool-suite-2.5.0.RELEASE-e3.5-updatesite.zip.

    When i install this archive site, i get the below error:

    Network connection problems encountered during search.
    Unable to access "jar:file:C:/temp/springsource-tool-suite-2.5.0.RELEASE-e3.5-updatesite.zip!/".
    Unable to access site: "jar:file:C:/temp/springsource-tool-suite-2.5.0.RELEASE-e3.5-updatesite.zip!/" [no entry name specified]

    i understand that this version of RAD is quite old, but that is what i have to work with, so any help is greatly appreciated.

    Thanks,
    Shane.

  • #2
    First, I want to make sure that you are using the update site in the correct manner. You should be doing this:

    1. Go to Help -> Install new software...
    2. Click "Add..."
    3. Select your zip file
    4. Add all of the features that you need to install

    You will also need to install AJDT, which may not be available from the update site that you downloaded. You can find archived update sites for AJDT here http://www.eclipse.org/ajdt/downloads/.

    Comment


    • #3
      Hi Andrew,
      Thanks for the reply.

      I was able to install AJDT 1.4.2 from the update site first http://archive.eclipse.org/tools/ajdt/32/update.

      I believe RAD 7.0.0.7 is built on eclipse 3.2.2. I was looking for an older version of spring ide, but only goes back to eclipse 3.5.

      See other downloads at: http://www.springsource.org/downloads/sts

      So i downloaded the update site zip file springsource-tool-suite-2.5.0.RELEASE-e3.5-updatesite.zip but to no avail.

      I then tried to follow the directions below, which got me further but now complains that
      Spring IDE Core (required) (2.5.0.201009031836) requires feature "org.eclipse.jdt (3.3.0)", or later version.

      http://forum.springsource.org/showth...ate-site/page3

      http://www.croz.net/index.php/hrv/content/download/1237/7708/file/spring-ide-update-site-2010-09-03_18-35-36-28.zip


      All i can do at this stage is see can i upgrade RAD to have a later version of eclipse.

      Regards,
      Shane.

      Comment


      • #4
        I didn't realize that that version of RAD was based on such an old version of Eclipse. There is not much you can do except update your RAD, or install STS separately from RAD.

        Comment

        Working...
        X