Announcement Announcement Module
Collapse
No announcement yet.
Spring IDE does not show aliased bean in depndency graph ? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring IDE does not show aliased bean in depndency graph ?

    Hi all,

    I am new to STS and Spring so this may be a stupid question.

    I am trying to learn someone else's code, so I am generating beans dependency graphs.
    I could not figure out how the code was working until I realized that aliased beans were not visible in the dependency graph.

    I have the following context:

    In core.xml
    <bean id="C"
    <property name="services" ref="startupServices"/>
    </bean>

    In local.xml
    <bean id="defaultStartupServices"/>

    In local.xml
    <alias name="defaultStartupServices" alias="startupServices"/>

    In container.xml
    <import resource="core.xml">
    <import resource="local.xml">
    <import resource="local-aliases.xml">

    I added those 4 files in Beans Support-->Config Files and I checked the option [Enable support for <import/> element ...]

    If I ask for a dependency graph for the node in container.xml-beans-beans-C, the dependency to defaultStartupService does not appear.

    Can you tell me why ?
    Is there a way to resolve alias before the graph is displayed ?

    Thanks

  • #2
    The beans graph does not resolve aliases when filling out the dependency tree. I've filed a feature request here:

    STS-2584: Beans graph does not resolve aliases when drawing dependencies
    https://issuetracker.springsource.com/browse/STS-2584

    Comment


    • #3
      Thanks for your reply. It would be a great feature.

      PW

      Comment

      Working...
      X