Announcement Announcement Module
Collapse
No announcement yet.
Using/installing Tomcat 6 with STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using/installing Tomcat 6 with STS

    I have tried a couple of times to install Tomcat 6 with STS but I encounter odd problems. The first odd problem is that when I start my Tomcat server in the Servers window, the server does not appear to be able to find the default Root webapp.

    Steps:
    1. install Tomcat 6 via STS preferences (verify the webapps folder contains Root)
    2. select Tomcat 6 server in Servers view
    3. click the start icon
    4. Check the console for successful start
    5. Open web browser
    6. Navigate to http://localhost:8080

    Expect to see Tomcat default page come up, Instead pick up a 404 error "The requested resource (/) is not available."

    The server is clearly running but the configuration appears to be hosed in some way.

    So I tried installing a guest instance of Tomcat (install tomcat 6, then run tomcat-instance-create) but now STS won't add the server to my server list.

    Any suggestions?

  • #2
    What version of STS are you using? And did you download STS from our distribution site (and unzip/tar) or did you install it into an Eclipse via an update site? If the latter, what version of Eclipse are you running?

    Comment

    Working...
    X