Announcement Announcement Module
Collapse
No announcement yet.
STS 2.9.1 & Grails Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.9.1 & Grails

    I have downloaded the latest STS zip and unzipped.

    I then try to add the grails extension and get the following error

    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Grails Support 2.9.1.201203221000-RELEASE (com.springsource.sts.grails.feature.group 2.9.1.201203221000-RELEASE)
    Missing requirement: SpringSource Tool Suite Grails Support (Core) 2.9.1.201203221000-RELEASE (com.springsource.sts.grails.core 2.9.1.201203221000-RELEASE) requires 'bundle org.codehaus.groovy.eclipse.core 0.0.0' but it could not be found
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Editor Support (Core) 2.9.1.201203221000-RELEASE (com.springsource.sts.grails.editor.groovy 2.9.1.201203221000-RELEASE)
    To: bundle com.springsource.sts.grails.core 0.0.0
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Support 2.9.1.201203221000-RELEASE (com.springsource.sts.grails.feature.group 2.9.1.201203221000-RELEASE)
    To: com.springsource.sts.grails.editor.groovy [2.9.1.201203221000-RELEASE]

    Anyone any ideas?

    Thanks,
    Kim

  • #2
    Did you checked MD5 sums of STS downloaded version?
    Can you check list of update sites? (just post it here if you do not know proper)
    Can you add info about your OS and java version?

    Comment


    • #3
      I have tried again on onother PC and get the same error

      Download URL http://download.springsource.com/rel....7.2-win32.zip

      Windows XP SP3
      JDK 1.6
      Update Site - SpringSource Update Site for Eclipse 3.7 - http://dist.springsource.com/release/TOOLS/update/e3.7
      Last edited by kimbad; Apr 16th, 2012, 03:07 AM.

      Comment


      • #4
        I think you need to install the Groovy Eclipse support. I think the error shows that the Grails tools are not able to find the Groovy Eclipse components that they require.

        You can install Groovy Eclipse from the extensions page.

        This is the telling bit of the error message:
        2.9.1.201203221000-RELEASE) requires 'bundle org.codehaus.groovy.eclipse.core 0.0.0' but it could not be found

        (Yes those errors can be rather confusing, a lot of garbage text and a bit of guess work needed to figure out which part of this text is the actual problem :-)

        Kris

        Comment


        • #5
          Attachment

          Hi Kris,

          I wondered if that was the problem but the option to install Groovy is not there. See attached screenshot.

          I would also have expected that requesting the install of the Grails extension would have resolved and installed the required dependencies.

          Cheers,
          Kim
          Attached Files

          Comment


          • #6
            That is not the extensions page I was referring to. This is the Eclipse UI for installing things via update site. That works also of course.

            You are correct, the Eclipse installer will try to find the things you need (dependencies), but it will not be able to find Groovy Eclipse unless you have added an update site that contains Groovy Eclipse.

            The "Extensions Page" that I was referring to is found on the STS Dashboard. The Dashboard usually opens automatically when you start STS. It has some 'news items' and things like that on it. At the bottom of that page is a Tab labeled 'Extensions'. If you click that tab you should be able to find Groovy Eclipse there.

            If you rather install from an update site manually (actually the Dashboard will really do the same anyway), you can use this update site to install Greclipse:

            http://dist.codehaus.org/groovy/dist...snapshot/e3.7/
            Last edited by Kris De Volder; Apr 16th, 2012, 05:11 PM. Reason: typos

            Comment


            • #7
              Hi Kris,

              Thanks for the help. This worked as you suggested.

              Cheers,
              Kim

              Comment


              • #9
                Hey!

                I fixed the composite update site that we use to point to the correct Mylyn version so that you don't need to add this specific Mylyn weekly snapshot site yourself. Sorry for the inconvenience, should work again out-of-the-box.

                And thanks for pointing us to this problem!!!

                -Martin

                Comment

                Working...
                X