Announcement Announcement Module
Collapse
No announcement yet.
Problem with Grails plugin dto 0.2.4 - please help Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Grails plugin dto 0.2.4 - please help

    Hi

    I am using Grails 2.0.1, I installed dto 0.2.4 plugin to convert domain classes and it installed successfully. But when I clean / run-app then it is showing following error. Please help here.
    "Error executing script RunApp: Cannot find plugin descriptor in plugin directory 'C:\Documents and Settings\sdhurjet\.grails\2.0.1\projects\cmlui\plu gins\dto-0.2.4'. (Use --stacktrace to see the full trace)"

    -- Sridhar

  • #2
    Hi, forgot to mention , it got created all DTOs corresponding to domain classes successfully. But when I clean/run it is giving problems.

    --Sridhar

    Comment


    • #3
      Can you try executing clean/run-app on the command line (outside of STS) to see if it is a problem with the tooling or a general Grails problem? I just created a simple project, installed dto (0.2.4) and did a clean/run-app and it was OK - however this was on a Mac (not windows).

      If it works on the command line but still fails in STS, please raise a jira on our issuetracker: https://issuetracker.springsource.com/browse/STS

      cheers,
      Andy

      Comment


      • #4
        Hi Andy,

        Same result when ran clean/run-app outside of STS.

        I tried by installing the plugin again inside STS though it's installed earlier(I did not uninstall), please find the logs below.

        | Loading Grails 2.0.1
        | Configuring classpath
        Cannot find plugin descriptor for path 'C:\Documents and Settings\sdhurjet\.grails\2.0.1\projects\cmlui\plu gins\dto-0.2.4'.
        | Configuring classpath.
        | Environment set to development.....
        | Installing zip dto-0.2.4.zip.....
        | Installed plugin dto-0.2.4
        | Resolving plugin JAR dependencies.....
        | Plugin installed.

        --Sridhar

        Comment


        • #5
          So if it is happening outside of STS as well, sounds like a grails issue. Can you try deleting your grails cache and retrying? So delete the C:\Documents and Settings\sdhurjet\.grails folder). I'll ask the grails guys about the message.

          Andy

          Comment


          • #6
            Hi

            It got woked for me. I just started everything fresh including STS, then it works.

            I have one doubt, while code check-in into source control, do we explicitly need to check in all the DTOs and other plugin created stuff or is there any thing like keeping the plugin information will automatically install everything when run the project.
            For example I saw some of the plug-in entries in the BuildConfig.groovy file like below

            plugins {
            runtime ":hibernate:$grailsVersion"
            runtime ":jquery:1.7.1"
            runtime ":resources:1.1.6"
            // Uncomment these (or add new ones) to enable additional resources capabilities
            //runtime ":zipped-resources:1.0"
            //runtime ":cached-resources:1.0"
            //runtime ":yui-minify-resources:0.1.4"
            build ":tomcat:$grailsVersion"
            }

            Do we have any thing like this. please let me know asap.

            -- Sridhar

            Comment


            • #7
              If you don't commit the generated DTOs I imagine you will just have to run the generate command again to reproduce them. However, you don't need to try and commit the dto plugin itself. Just having the dependency expressed (BuildConfig.groovy/application.properties) should ensure it is around when you need it (the first attempt to interact with the project should grab it). When I played with it the dto plugin reference was in the applications.properties file.

              cheers,
              Andy

              Comment


              • #8
                HI Thanks.

                It is working, by putting the DTO plugin info in BuildConfig.Groovy.

                Thanks

                Sridhar

                Comment

                Working...
                X