Announcement Announcement Module
Collapse
No announcement yet.
STS 2.9.1 Grails Plugin Manager does not open Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.9.1 Grails Plugin Manager does not open

    Hi,

    i am starting with grails and use the STS 2.9.1. When i am trying to use the Grails Plugin Manager i got an popup with "Resolving list of available plugins" and at the first start the list was shown in the console window. But the Plugin manager does not open. I used serveral times but nothing happens. Is there a extension or plugin missing? I am using a windows 7 64bit.

    regards,
    Thomas

  • #2
    Same here

    Did an update from 2.7 to 2.9.1 this morning and plugins in a grails project don't show in the Project Explorer and Plugin Manager won't open (successfully) to try to give things a push.

    Old project: Grails 1.2.2

    -- On edit, talked the client into upgrading Grails to 1.3.7 and so finessed the entire issue.
    Last edited by jjones42; Apr 4th, 2012, 03:20 PM.

    Comment


    • #3
      I am using a fresh install with Grails 2.0.1.

      Comment


      • #4
        It is likely you are hitting this bug that I recently fixed:
        https://issuetracker.springsource.com/browse/STS-2490

        Can you check your eclipse error log and see if the null pointer exception is there (as reported in the bug). (Get the error log via menu 'Windows >> Show View >> Error Log'.

        If this is the bug you are hitting then you can find a possible workaround in the bug report. Also, you can update the Grails tooling from the nightly update site to get the bugfix.

        Let me know if you need more help with any of that.

        Kris

        Comment


        • #5
          The workarround didn't help me.
          I'm trying to get a nigthly build but I can find it.

          How can I update my STS with the fix?

          Comment


          • #6
            The nightly update site for STS is here:

            http://dist.springsource.com/snapsho...S/nightly/e3.7

            Define that as an update site and then grab the Grails tools from it.

            Andy
            ---
            Andy Clement

            Comment


            • #7
              After update from Nightly Build it works.

              Thanks Andy

              Comment


              • #8
                When I add this site it has version 3 which is M1 is there any other way to fix it? If not what do I need to install whenever I select one that say's tools it says the dependencies aren't met. I've cleared out .grails and reloaded STS etc... with the same issue.

                Comment


                • #9
                  Unfortunately no, there is no other way to really fix except update to the version that has the bugfix in it.
                  That is, assuming you tried the workarounds suggested in the bug report and they didn't work for you.

                  If you tell us what dependencies you are missing, we may be able to tell you what update site to add for this dependency.
                  Is there an error message? If so please include the error message with your question.

                  Comment


                  • #10
                    I usually only have STS with the Grails Plugin installed, so which of the updates should I grab all or just a few?
                    I'm currently setup on 2.9.1 with Grails 1.3.7

                    For tools I see : (all versions are 3.0.0.201204250733-SNAPSHOT)
                    Under
                    Core / STS : SpringSource Tool Suite
                    Extensions / STS :
                    SpringSource Tool Suite Grails Support
                    SpringSource Tool Suite Maven Support
                    SpringSource Tool Suite Roo Support
                    SpringSource Tool Suite Runtime Error Analysis Support
                    SpringSource Tool Suite tc Server Tools
                    SpringSource Tool Suite Tutorials
                    SpringSource Tool Suite VMware Integration

                    Uncategorized : "SpringSource Tool Suite Package"

                    If I select the
                    SpringSource Tool Suite Grails Support
                    I get this:
                    Your original request has been modified.
                    "SpringSource Tool Suite Grails Support" is already installed, so an update will be performed instead.
                    Cannot complete the install because one or more required items could not be found.
                    Software being installed: SpringSource Tool Suite Grails Support 3.0.0.201204250733-SNAPSHOT (com.springsource.sts.grails.feature.group 3.0.0.201204250733-SNAPSHOT)
                    Missing requirement: SpringSource Tool Suite Spring Configuration Editor (UI) 3.0.0.201204250733-SNAPSHOT (com.springsource.sts.config.ui 3.0.0.201204250733-SNAPSHOT) requires 'bundle org.eclipse.mylyn.tasks.ui [3.7.0,4.0.0)' but it could not be found
                    Cannot satisfy dependency:
                    From: SpringSource Tool Suite (required) 3.0.0.201204250733-SNAPSHOT (com.springsource.sts.feature.group 3.0.0.201204250733-SNAPSHOT)
                    To: com.springsource.sts.config.ui [3.0.0.201204250733-SNAPSHOT]
                    Cannot satisfy dependency:
                    From: SpringSource Tool Suite Grails Support 3.0.0.201204250733-SNAPSHOT (com.springsource.sts.grails.feature.group 3.0.0.201204250733-SNAPSHOT)
                    To: com.springsource.sts.feature.group [3.0.0,3.1.0)

                    Thank you for your help
                    Last edited by gcstang; Apr 25th, 2012, 03:28 PM.

                    Comment


                    • #11
                      Would going back to 2.9.0 fix this issue?

                      I've also noticed that the Plugin search site is down, would that have anything to do with it?

                      http://grails.org/plugin/search

                      I'm getting a 503 and when it does come up sporadically it's really super slow.

                      Comment


                      • #12
                        To fix your problem you only need to update the 'Grails Support' tools.
                        When you do that, the installer will figure out dependencies.

                        It looks like you can't upgrade because of this

                        'bundle org.eclipse.mylyn.tasks.ui [3.7.0,4.0.0)' but it could not be found.

                        Mylin is softwarethat comes from Eclipse (i.e. it isn't part of STS itself, but it normally comes bundled when you download
                        the full STS package, which contains Eclipse inside). Normally the installer should be able to find it in one of the update sites that are automatically configured with STS. But there has been recent version changes in mylin so that could be the reason for the problem.

                        Let me figure out what update site you could add to satisfy this dependency.

                        I'll get back to you shortly.

                        Kris

                        Comment


                        • #13
                          I use the full zip version to install if that helps.

                          Any idea if going back to 2.9.0 would fix the issue?

                          Comment


                          • #14
                            Can you please try adding this site:

                            http://download.eclipse.org/mylyn/snapshots/3.7/

                            to your list of 'Available Software sites' (there is a link just below the box where you past an update site address, click that link and add this site.

                            Then try to update the Grails tooling again. Make sure that you have 'Contact all Update sites' box checked so that the installer will be able to find mylin version 3.7.

                            Let me know how that goes.

                            Kris

                            Comment


                            • #15
                              > Any idea if going back to 2.9.0 would fix the issue?

                              If you mean the plugin manager problem. You could try but I don't think it will help. The bug has been there for a rather long time. It has just been latent. It is only triggered by certain contents of the plugin list file from grails.org. Apparantly the conditions that triggered this didn't happen much before. Since the trigger for the bug is in the contents of a downloaded file. It doesn't really help if you use 2.9.0 or 2.9.1. Only upgrading to a version that has the bugfix will really help avoid the problem.

                              Kris

                              Comment

                              Working...
                              X