Announcement Announcement Module
Collapse
No announcement yet.
Getting Started Page Title Module
Move Remove Collapse
This is a sticky topic.
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting Started

    Here are some good resources for getting started with the SpringSource Tool Suite:


    Hope this gives you a good start!!!
    -Martin

  • #2
    trying to get STS or the GG tool suite install on a Mac 10.8. i've tried both the STS and GG dmg and tar.gz.

    None of them actually start. i can "install" the dmg but when i run the tool suite it just appears to hang.

    Help please.

    Comment


    • #3
      Hey!

      When you say that you can "install" the DMG, you mean that the STS installer ran successfully (you clicked through all the installer wizard pages), correct? And what happens when you start "STS" afterwards? Does the splash screen appear? What do you see when it hangs?

      -Martin

      Comment


      • #4
        yes, i can run thru the installer. but as soon at it starts the tool suite all i get is the 'splash screen'. i've let it sit for many minutes and no result. Watching the 'activity monitor' on the mac it shows some activity. I have to Force Quit to get out of it.

        i had looked over the tool suite many months back and it worked but this was prior to 10.8

        Comment


        • #5
          Can you capture a thread dump while it is hanging? (using jps and jstack)

          Comment


          • #6
            I'm a newbie to java and groovy. How do i go about getting the dump.

            Comment


            • #7
              Hey!

              When the splash screen is hanging around there and nothing happens, go to your console or terminal app (terminal.app on Mac, cmd on Windows, command line console on Linux) and type in jps. Then you get a list of java processes and their IDs. If you are not running another java process, you should be able to figure out which one is for the STS process. Then type "jstack " followed by the process ID and hit enter. That produces a dump of all the threads that are running in that Java process. That output would be quite useful to figure out why STS is not starting up as expected.

              HTH,
              Martin

              Comment


              • #8
                Hi,
                I'm starting learning spring and all technologies related to this framework. I'm at the very beginning. I know this is an old thread, but I'm writing related to this...I thought it was unuseful to open a new one.

                I'm trying to make such tutorial working on Centos 6.5. I'm using STS 3.4.
                Firstly I tried to configure manually from scratch. Let me ask some question (I'm sorry if they are very stupid questions)
                After first setting and paths and classes, it is not able to create executable jar file (as-is) using
                Code:
                java -jar target/gs-rest-service-0.1.0.jar
                no main manifest attribute, in target/gs-rest-service-0.1.0.jar
                it gives the error related to a missing manifest file. I solved reading this answer (is this a missing?)
                Ok, done, what's the next step?
                Tomcat (7) is installed and running.
                a) What should I do now? What should I copy and where?

                I installed and successfully imported the tutorial into STS 3.4.
                I created a new server setting tomcat 7 paths.
                I pressed the Run as Application button, selecting the Application.java (among all options available in the dialogue window)

                It starts printing some log and then it fails with the following error messages

                Could you provide any suggestions?

                Thanks in advance
                Last edited by lordcenzin; Dec 13th, 2013, 05:59 AM.

                Comment


                • #9
                  Hey!

                  The idea behind the Getting Started guides is that you import them into your STS 3.4.0 (using the wizard "Import Getting Started Content"). In case you imported the completed version of the guide, you can start the main class of the guide (usually called "Application") as a regular Java application, just right-click on the Application class and select "Run as Java application". And thats it. You don't need to configure a Tomcat server in STS, it automatically starts embedded in your application.

                  Here is a short video that demonstrates the usage of the getting started guides, using the Restful Web Service as an example as well:

                  https://www.youtube.com/watch?v=8Jc28CONVUc

                  HTH,
                  Martin

                  Comment

                  Working...
                  X