Announcement Announcement Module
Collapse
No announcement yet.
update site for older versions of STS plugin Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • update site for older versions of STS plugin

    We are currently using Eclipse 3.7.1 EE with the STS plugin 2.8.1.

    We had been installing the plugin from http://dist.springsource.com/release/TOOLS/update/e3.7. But since the release of 2.9.0, it seems that 2.8.1 is no longer available there. I was expecting to see older versions when I unchecked the box labeled "Show only the latest versions of software", but I did not. Is there a different update site that has the older versions? I don't want new developers creating their development environment using 2.9.0 until we have time to test it out with the rest of our ecosystem.

    A related question: is it possible to archive the STS plugin? Some plugins (e.g. JRebel) are provided in a bundle that can be downloaded and stored locally. This would let us remove one dependency on network connectivity, and also generally feel like we're a bit more in control of our dependencies.

    Thanks,
    Dan

  • #2
    Hi Dan!

    EDIT --- changed URL to be correct.

    You can go to http://www.springsource.com/developer/sts and expand the "Other Downloads" section. There you can download an archived version of the update site, that you can then use locally or from your own network. That section contains older versions of STS as well (including their zipped update sites).

    If you wanna use the STS update site for 2.8.1 online, you can use:
    http://download.springsource.com/rel...1.RELEASE/e3.7

    The only thing that might be challenging here is how to deal with those parts that are not on the STS update site itself, but consumed from Groovy-Grails-related or AJDT update sites. So if you are using Groovy/Grails, you might also wanna have a copy of their update site locally that matches the STS version you are using. But just in case, you should be able to download the archived update sites of Groovy-Eclipse from the Groovy-Eclipse project homepage. The same if true for AJDT.

    HTH,
    Martin
    Last edited by Andrew Eisenberg; May 16th, 2012, 12:18 PM. Reason: bad url

    Comment


    • #3
      Thanks, Martin. I will give that a try. (I had hoped to reply with my results, but haven't got back to this topic yet.)

      Comment


      • #4
        Thanks for the quick update. Let us know if that works for you.

        Cheers,
        -Martin

        Comment


        • #5
          Hi Martin,

          I get a page not found error with this address: http://www.springsource.com/developer/sts. It's been several months since I started this thread, so perhaps the URL has changed?

          I also have the same questions for the STS Gradle Support. Is there a stable URL for exactly version 2.8.0, which was current a number of months ago, but is no longer? And is there a way to download an offline bundle?

          Thanks,
          Dan
          Last edited by Martin Lippert; May 16th, 2012, 01:35 PM.

          Comment


          • #6
            The correct URL is http://www.springsource.com/developer/sts (.com, not .org. I'll edit Martin's post above).

            Comment


            • #7
              Right, sorry for the typo... Fixed this in my post above.

              -Martin

              Comment

              Working...
              X