Announcement Announcement Module
Collapse
No announcement yet.
Workspace Configuration hanging endlessly - 2.9.0.M2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Workspace Configuration hanging endlessly - 2.9.0.M2

    I took STS 2.9.0.M2 and added Grails Tooling, Groovy support and Grails 2.0.0

    Started tried to create first project and this kicked off workspace configuration - this just hangs until I kill the STS process.

    Environment is Windows XP SP3 (corporate enviroment ;-) ) on a Dell dual CPU, 2GB RAM machine.

    NOTE that Command Prompt is disabled, so I use MinTTY and bash (from CygWin package).

    I am aware that Grails 2.0.0 commands have an issue where user input isn't accepted by the grails scripts under CygWin, but I'm not sure if we are getting to there.

    1) Is there a way to generate some debug info so I can track down the problem?

    2) Does STS have it's own Shell that it uses to spawn commands, or does it rely on Command Prompt?

    3) If Command Prompt is used, how can I configure to use CygWin ?

    Regards,

    Gordon

  • #2
    Uggh...not having access to a terminal is a bummer. There are 2 ways to launch STS. One launches the executable directly (with a .exe extension), and the other opens up a terminal to do the actual launching (not sure what the file is called on windows, but it may be STS.bat or STSc.exe or something similar). Maybe you'll be able to launch this.

    Or, if you can launch from a cygwin prompt, then stdout and stderr will be directed there.

    Likely, though the errors are in STS's error log. Window -> Show View -> Other -> Error log. There are likely some relevant error messages there.

    What is the exact stage that you made it to? Did you successfully create a project? Did "refresh dependencies" complete? What does the console view contain?

    Also, if you do have a hanging STS, then running jps and jstack could get you some good information as well (if you have access to these commands).

    It could be that you have a firewall/network problem. Make sure that you have your proxies configured properly inside of STS.

    Comment


    • #3
      Andrew,

      Yeah, trying to do modern development in a locked down corporate environment is full of challenges that suck :-(
      Hey Ho! Open Source will prevail over the dark M$FT side... ;-)

      Originally I tried using STS 2.8.1 but had issues with extensions downloading, so thought I would pick up the bleeding edge...

      After I downloaded STS 2.9.0.M2 I was able to download the extensions, then I think I tried to create a grails project - this is where STS hung up - window shows configuring workspace. I had to use Task Manager to kill STS, then another window popped up saying it was shutting down - but this hung for ages. Now, everytime I start STS it goes straight into this endless loop.

      Today I got into the same issue while I was trying to note down more information for you, but managed to close STS using the GUI - another window popped up to say it was closing everything down and this time it completed.

      When I restarted STS from the cywin prompt again I noticed new downloads happening in the STS window, RSS feeds updated and now STS is ready for work - weird eh?


      In the bash window (Cygwin) and keep getting the following error:

      bash-3.2$ pwd
      /cygdrive/g/GENERAL/devenv/springsource/springsource-tool-suite-2.9.0.M2-e3.7.1-win32/springsource/sts-2.9.0.M2
      bash-3.2$ ./STS.exe
      02-Feb-2012 10:03:44 java.util.prefs.WindowsPreferences <init>
      WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
      [Fatal Error] :1:1: Premature end of file.

      It looks like STS is trying to modify the Registry... ? Is this important if it fails?


      Thanks for taking the time to respond...

      Gordon

      Comment


      • #4
        Final update on this:

        I'm still getting the Windows RegCreateKeyEx, but I have now managed to create a grails project, add a domain and controller and exceute the code, so I'm up and running.

        Comment


        • #5
          I'm surprised that STS is trying to write to the registry. It looks like STS is using the registry to store some user preferences. I thought this was all done using the file system, but I guess I was wrong. Let me know if you have any more problems. It is not easy to run Eclipse or STS in a locked-down environment.

          Comment


          • #6
            Additional note:

            I'm pretty certain that I did a windows launch (double click icon) of STS the first time. This could have hung because it was trying to write the error log to stderr or something similar.

            When I followed Andrew's recommendations, I launched from the cygwin bash prompt and everything cleared itself up.

            My recommendation when running STS in a Windows XP, locked down environment with Command Prompt disabled, start STS from an alternative shell such as Cygwin bash.

            HTH

            Gordon

            Comment

            Working...
            X