Announcement Announcement Module
Collapse
No announcement yet.
MVC template issues Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • MVC template issues

    Hi,

    I just downloaded STS, and I'm giving it a try by creating an MVC template web app, selecting New -> Spring Template Project -> Spring MVC Project.

    The project is created, but then there is a compilaton error in the sample home.jsp file, first line:

    Code:
    <%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>
    as the page itself doesn't actually use JSTL, I can just remove this line for the project to compile correctly. Then I go to Run -> Run on Server..., select the server that comes with STS, the server starts up, but the app is not mapped to the URL which STS opens. (in my case, this would be http://localhost:8080/test). the warning on the console says:

    Code:
    WARN : org.springframework.web.servlet.PageNotFound - No mapping found for HTTP request with URI [/test/] in DispatcherServlet with name 'appServlet'

    I looked around for a while, but couldn't find an immediate fix. The server does have to the project name in its classpath, according to the configuration settings.

    How can one make the MVC template work? Shouldn't a sample template 'just work'?


    Akos

  • #2
    Hi!

    This is a weird issue with the webtools tooling in Eclipse. Please do a clean build of the project "Project -> Clean..." and the error disappear.

    This is the related issue in the JIRA:
    https://issuetracker.springsource.com/browse/STS-2249

    HTH,
    Martin

    Comment


    • #3
      Originally posted by Martin Lippert View Post
      Hi!

      This is a weird issue with the webtools tooling in Eclipse. Please do a clean build of the project "Project -> Clean..." and the error disappear.

      This is the related issue in the JIRA:
      https://issuetracker.springsource.com/browse/STS-2249

      HTH,
      Martin
      indeed - and it works now!

      Comment


      • #4
        Glad to hear that!!!
        Thanks for the feedback!

        -Martin

        Comment

        Working...
        X