Announcement Announcement Module
Collapse
No announcement yet.
Two problems when creating a simple roo script with STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Two problems when creating a simple roo script with STS

    Hi,

    I did a fresh install of STS 2.8.1 and created a new Spring Roo project in a new workspace. I then invoked the following simple Roo script:


    Code:
    persistence setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY
    entity --class ~.server.domain.Person
    field string --fieldName name --sizeMin 3
    field number --fieldName age --type java.lang.Integer
    First problem is I got several Java Problems (51). I needed to do a project clean to clear this problem.

    Then I did the following two commands:

    Code:
    web mvc setup
    web mvc scaffold --class ~.web.MyController
    Then I got the following 2 JSP Problems:
    Code:
    Description	Resource	Path	Location	Type
    ErrorCMDocument_load_exception=An error occurred while loading document {0} with publicId {1}	load-scripts.tagx	/t4/src/main/webapp/WEB-INF/tags/util	line 12 and 13
    I will open a JIRA ticket

  • #2
    I found that if I go to Window/Preferences/Validation/Tag Library Descriptor Validator and I click under the Settings column the ... button I can add a file name rule for load-scripts.tagx under a new Exclude Group and this will remove the error. This I believe is just a work around.

    Comment

    Working...
    X