Announcement Announcement Module
Collapse
No announcement yet.
AJP in the STS vFabric Server Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • AJP in the STS vFabric Server

    Hi, I'm having a hard time activating the AJP connector. I've changed the file server-fragment.xml in C:\springsource\vfabric-tc-server-developer-2.6.2.RELEASE\templates\ajp\conf to:
    Code:
    <?xml version='1.0' encoding='utf-8'?>
    <Server>
    	<Service name="Catalina">
    		<add:Connector executor="tomcatThreadPool"
    				port="${http.port:8009}"
    				protocol="org.apache.coyote.ajp.AjpProtocol"
    				connectionTimeout="20000"
    				redirectPort="${http.port:8080}"
    				acceptCount="100"
    				maxKeepAliveRequests="15"/>
    	</Service>
    </Server>
    What I'm aiming for: The linux server in my LAN running apache httpd should be able to forward requests to my development machine. In order to do that, I've created the following config on the linux server under apache httpd, using mod_proxy:
    Code:
    ProxyRequests On
    ProxyPass /tpro ajp://192.168.2.22:8009/tpro
    
    <Proxy *>
       AddDefaultCharset off
       Order deny,allow
       Deny from none
       #Allow from .example.com
    </Proxy>
    My problem is, that calling http://linuxserver/tpro fails after trying to connect for quite a while.

    The apache httpd log shows the following:
    Code:
    ==> /var/log/httpd/access_log <==
    192.168.2.22 - - [22/Jan/2012:16:54:37 +0100] "GET /tpro HTTP/1.1" 503 399
    
    ==> /var/log/httpd/error_log <==
    [Sun Jan 22 16:56:37 2012] [error] (70007)The timeout specified has expired: proxy: AJP: attempt to connect to 192.168.2.22:8009 (192.168.2.22) failed
    [Sun Jan 22 16:56:37 2012] [error] ap_proxy_connect_backend disabling worker for (192.168.2.22)
    [Sun Jan 22 16:56:37 2012] [error] proxy: AJP: failed to make connection to backend: 192.168.2.22
    The machine 192.168.2.22 is the development machine with STS installed.
    In fact, the application IS working, I can invoke it by calling http://192.168.2.22:8080/tpro/

    Can you help me with that?
    Kind regards
    Michael

  • #2
    Hey Michael!

    Sounds like a problem with the tc Server configuration what might be better placed in the tc Server forums.

    HTH,
    Martin

    Comment

    Working...
    X