Announcement Announcement Module
Collapse
No announcement yet.
Update Grrails dependencies times out, works fine when used via command line Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Update Grrails dependencies times out, works fine when used via command line

    Hi

    I'm running into into problems when STS (I think) resolves Grails dependencies. After clicking refresh dependencies it hangs for a while but later exits with a timeout related error message.

    I'm sitting behind a corporate firewall but have proxy settings configured correctly and have settings.xml updated to point to our internal Nexus repo. I can access the outside world just fine when updating eclipse plugins etc.

    When running via the command line my app starts up just fine and dependencies seems to be resolved.

    I'm using STS 2.8.1.RELEASE and have installed the latest updates. I've tried using both Grails 2.0 and 1.3.7 .


    Error messages:

    Code:
    The command 'C:\dev\java\jdk1.6.0_21\bin\javaw.exe (19 Jan 2012 08:37:53)' was terminated because it didn't produce new output for some time.
    
    See details for the output produced so far.
    
    If you think the command simply needed more time, you can increase the time limit in the Grails preferences page.
    
    See menu Windows >> Preferences >> Grails >> Launch
    ------System.out:-----------
     Welcome to Grails 1.3.7 - http://grails.org/
    Licensed under Apache Standard License 2.0
    Grails home is set to: C:\dev\tools\grails-1.3.7\
    
    Base Directory: C:\dev\workspaces\playground\app
    Resolving dependencies...
    ------System.err:-----------
    
    Terminating process: Timeout: no new output for 60000 milliseconds
    Code:
    The command 'C:\dev\java\jdk1.6.0_21\bin\javaw.exe (19 Jan 2012 08:54:14)' was terminated because it didn't produce new output for some time.
    
    See details for the output produced so far.
    
    If you think the command simply needed more time, you can increase the time limit in the Grails preferences page.
    
    See menu Windows >> Preferences >> Grails >> Launch
    ------System.out:-----------
     | Loading Grails 2.0.0
    | Configuring classpath
    | Downloading: jtds-1.2.5.pom.sha1
    ------System.err:-----------
    
    Terminating process: Timeout: no new output for 60000 milliseconds
    I've tried upping the timeout but same error message.

    Cheers,
    Micke

  • #2
    Inside of STS, you need to set your proxy. Go to Preferences -> General -> Network Connections.

    Comment


    • #3
      Hi

      I already have the proxy configured, when opening the dashboard I can see see news and download and install plugins. That means that the proxy configuration is ok right?

      Comment


      • #4
        Actually, I don't think that setting the proxy configuration inside STS network preferences has an effect on Grails. This is because Grails is running as an external process from STS. You would have to set the proxy for grails in some other way.

        Perhaps using the grails proxy related commands will work:
        Eg. see here: http://grails.org/doc/2.0.x/ref/Comm...set-proxy.html

        Alternatively, you can also try setting proxy related Java system properties via the Grails preferences page at:
        Windows >> Preferences >> Groovy >> Grails >> Grails Launch.

        There's a table there that you can add system properties. These settings should be passed on to any grails command started from within STS.

        The properties you will likely have to set are stuff like "http.proxyHost" and "http.proxyPort". See here for some more info
        http://docs.oracle.com/javase/1.4.2/...roperties.html

        Kris

        Comment

        Working...
        X