Announcement Announcement Module
Collapse
No announcement yet.
Spring source tool suite Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring source tool suite

    I'm posting this thread in hope that some one already had this problem and
    found a way to solve it.

    I'm currently developing a spring web app with a strong client side component (extjs) and the IDE is constantly crashing i had to disable javascript building, validations and all and still slow as hell and crashes constantly
    i lost count on how many times i had reinstaled the IDE.
    Above all this Javascript code completion doen't work only for things in the same file (and if it doesn't crash)

    I have the 2.8.1 version of STS, currently working with a i5 2G with 8G ddr3....
    Theirs got to be something that i can do.

    Currently looking for a solution even if it means changing IDE.

    thanks in advance.

  • #2
    Hi!

    The JavaScript support in STS is part of the Eclipse JEE distribution that is STS is built on top of, so there is not much we can do here about concrete bugs or so. Nevertheless I would suggest to capture stack traces and log files for those crashes and problems you are seeing and submitting them to the JavaScript component at Eclipse to get them fixed.

    If you need any assistance with that, I am happy to help you!

    Cheers,
    -Martin

    Comment


    • #3
      Having the same issue. Did you find a resolution to share?

      Comment


      • #4
        Hey!

        Which version of STS do you use?

        -Martin

        Comment


        • #5
          Currently 2.9.0 I suppose this could be a good place to start in obtaining the latest version.

          Comment


          • #6
            Hey!

            I would at least try STS 3.1.0 on Eclipse 3.8. It uses the latest release of Eclipse Webtools (which is responsible for the JS tooling at the moment) and in case the root of the problems where in that area, a newer version might help.

            Otherwise you could also wait for STS 3.2.0 (on Eclipse 3.8), which we will release shortly (in around 3 weeks from now). That will be based on Eclipse Juno SR2, the latest maintenance release of Eclipse that is coming out at the end of this week.

            HTH,
            Martin

            Comment


            • #7
              Martin - will upgrade and look forward to the future release. Thanks for the replies ;-)

              Comment

              Working...
              X