Announcement Announcement Module
Collapse
No announcement yet.
Problem installing Groovy Eclipse 1.8 Compiler in STS 2.9.0 nightly Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem installing Groovy Eclipse 1.8 Compiler in STS 2.9.0 nightly

    I'm running Eclipse 3.7.1 + STS 2.9.0 nightly (2.9.0.20120105726-SNAPSHOT). When I try to install Groovy 1.8 from Dashboard -> Extensions, I get the following error:

    Code:
    Problems occurred while performing installation: Operation details
        Operation details
          Cannot complete the install because of a conflicting dependency.
            Software being installed: Groovy Compiler 1.8 Feature 2.6.0.xx-20111212-0900-e37-RELEASE (org.codehaus.groovy18.feature.feature.group 2.6.0.xx-20111212-0900-e37-RELEASE)
            Software currently installed: Groovy-Eclipse M2E integration 2.6.1.xx-20120104-1600-e37 (org.codehaus.groovy.m2eclipse.feature.group 2.6.1.xx-20120104-1600-e37)
            Only one of the following can be installed at once: 
              Groovy-Eclipse plugin 2.6.1.xx-20120104-1600-e37 (org.codehaus.groovy.eclipse 2.6.1.xx-20120104-1600-e37)
              Groovy-Eclipse plugin 2.6.0.xx-20111212-0900-e37-RELEASE (org.codehaus.groovy.eclipse 2.6.0.xx-20111212-0900-e37-RELEASE)
            Cannot satisfy dependency:
              From: Groovy-Eclipse Feature 2.6.1.xx-20120104-1600-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.6.1.xx-20120104-1600-e37)
              To: org.codehaus.groovy.eclipse [2.6.1.xx-20120104-1600-e37]
            Cannot satisfy dependency:
              From: Groovy-Eclipse M2E integration 2.6.1.xx-20120104-1600-e37 (org.codehaus.groovy.m2eclipse.feature.group 2.6.1.xx-20120104-1600-e37)
              To: org.codehaus.groovy.eclipse.feature.feature.group [2.6.1.qualifier,3.0.0)
            Cannot satisfy dependency:
              From: Groovy Compiler 1.8 Feature 2.6.0.xx-20111212-0900-e37-RELEASE (org.codehaus.groovy18.feature.feature.group 2.6.0.xx-20111212-0900-e37-RELEASE)
              To: org.codehaus.groovy.eclipse [2.6.0.xx-20111212-0900-e37-RELEASE]
    It looks like the 1.8 compiler depends on an earlier version of the Groovy Eclipse plugin than what's included with STS 2.9.0 nightly. Are there any workarounds to get the Groovy 1.8 compiler installed?

  • #2
    You have a snapshot version of Groovy-Eclipse, but from the dashboard, we only provide the release version of the compiler. If you want to install the latest version, you must go through the install manager and install the compiler through the snapshot update site for groovy-eclipse.

    Comment


    • #3
      That worked, thanks!

      Comment

      Working...
      X