Announcement Announcement Module
Collapse
No announcement yet.
Installing Subclipse Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing Subclipse

    Hi,
    I have installed STS - 2.8.1.RELEASE
    Now I want to install subclipse to access my SVN repository.

    When I try to install Polarion - http://www.polarion.org/projects/sub...0/update-site/

    the installer tells me the following:
    Code:
    Cannot complete the install because one or more required items could not be found.
      Software currently installed: Shared profile 1.0.0.1324138564078 (SharedProfile_com.springsource.sts.ide 1.0.0.1324138564078)
      Missing requirement: Shared profile 1.0.0.1324138564078 (SharedProfile_com.springsource.sts.ide 1.0.0.1324138564078) requires 'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be found
    With STS Maeven is installed as far as I understood. I see installed in my eclipse:
    org.maven.ide.eclipse.wtp.feature

    I don't see in my list: org.maven.ide.eclipse.

    Where can I find org.maven.ide.eclipse? Do I really need to install this one? Sorry I am a bit lost.

    Did someone out there install Subclipse on STS?

    Thanks for sharing...

  • #2
    Hi!

    Did you try to install Subclipse from the Extension install? Its just one click, you don't need an update site for that, and it works with a fresh STS 2.8.1 installation.

    The error message seems to indicate that there is a component depending on the old Eclipse Maven integration, but I am not able to figure out which component that could be from that snippet. Is it a fresh STS 2.8.1 installation that you are using or an upgraded one?

    Definitely try the extension install from the Dashboard and let me know if that works!

    HTH,
    Martin

    Comment


    • #3
      Hi Martin,

      Thanks for your hints. Obviously you are right. Using the Extension tab is the right way to do it. I did not think of using this, as this is not the way I was doing with my old Eclipse. I was doing it with the marketplace. I am new to STS.

      Nevertheless, here is my story.

      After receiving your mail I have tried installing subclipse from the Extension tab on the dashboard. Unfortunately at this stage the installer gave me the same error.

      Code:
      requires 'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be found
      So, since you were mentioning that it should work on a brand new installed STS I decided to reinstall everything. And from a brand new installed version it worked. I installed Subclipse no problem.

      The only thing I had installed before was Grails (from Language and Frameworks) and Grails Support (from Language and Framework Tooling).

      After I managed installing Subclipse, I reinstalled Grails... and now I have everything installed.

      I cannot say if it is important to install Subclipse first, but from my very brief experience it seems to be important.
      One more detail, which I don't know if it is important to say. My system runs Windows 7 64 bits, and I have installed springsource-tool-suite-2.8.1.RELEASE-e3.7.1-win32-x86_64-installer

      Martin, thanks for your support.
      Cheers

      Jean

      Comment


      • #4
        Hey Jean!

        Glad to hear its working. Looks like your previous installation of STS had some other components installed that somehow produced this wired behavior. I will take a look at this again to see if I can find out what was going wrong in that case. Thanks for the additional details.

        Cheers,
        -Martin

        Comment

        Working...
        X