Announcement Announcement Module
Collapse
No announcement yet.
classpath problems in 2.9M1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • classpath problems in 2.9M1

    I created a web project with Roo1.2.0.Release. I can run "mvn install" and use the project with "mvn tomcat:run". Yet when I open it I have massive classpath problems in STS2.9M1 and maven libraries don't show up under Libraries. Symptom is that M2_REPO begins all dependencies. So I set a new M2_REPO variable that points to my maven 2 repository root.
    Now they all get the warning "Classpath entry M2_REPO/[product]/2.x.x/[product]2.x.x.jar will not be exported or published. Runtime ClassNotFoundExceptions may result".

    The project also sets itself to jdk1.4 when I run "mvn eclipse:eclipse". This is easy to reset in the project settings however, but it's a first.


    Does this sound familiar? How did you solve it?
    Last edited by MiB; Dec 21st, 2011, 10:28 PM.

  • #2
    Is there a reason why you are running mvn eclipse:eclipse? I normally do not use the maven eclipse plugin for my roo projects. If you run mvn eclipse:clean and then import the project into STS as a maven project, it should no longer be using the M2_REPO variable and the classpath will be managed by m2eclipse.

    Comment


    • #3
      The reason is probably I picked this up from Ben Ales demo of last year.
      Skipping the goal eclipse:eclipse and just reimporting after executing the goal "eclipse:clean" I have not tried before. I'll make a note of it. Thank you.

      Comment

      Working...
      X