Announcement Announcement Module
Collapse
No announcement yet.
Cannot install tomcat within STS 2.8.1 on Mac OS X Lion Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot install tomcat within STS 2.8.1 on Mac OS X Lion

    I'm trying to install Tomcat within STS, but 'Download and install' button always appears to be disabled. STS installation folder and workspace folder both have write permission granted to current user. Any ideas?

  • #2
    Hey!

    Can you provide some more details what exactly you are trying to do, maybe with some steps to reproduce? As a workaround, you can always download a Tomcat server manually from Apache and add that to the list of configured servers via the preferences.

    Another option would be to use the tc Server that ships with STS by default, so you don't need to download/install/configure anything manually.

    HTH,
    Martin

    Comment


    • #3
      Martin Lippert, thanks for your reply. It's absolutely no problem for me to install Tomcat outside STS and, of course, I can use tc Server as well, but in previous releases this function works well.

      My steps are:

      1. Call the 'New Server' dialog from 'Servers' view (New-->Server).
      2. Choose 'Tomcat v7.0 Server' from 'Select the server type' tree view and click 'Next' button.
      3. At this step I expect to see available Tomcat version left to 'Download and Install...' button, but there is no text and button appears to be disabled.

      P.S. Sorry for my english, but I think this helps to describe my problem.

      Comment


      • #4
        Hi!

        Thanks for the additional details. Did you try this also with a plain Eclipse Indigo SR1 installation, just to make sure this is related to STS and not the standard Tomcat support of Eclipse Indigo?

        -Martin

        Comment


        • #5
          Result is the same with Eclipse. Thank you, Martin, I address this problem to Eclipse community.
          Attachment
          Attached Files

          Comment


          • #6
            Thanks!!! Let us know what the solution to this is or maybe post the Eclipse bugzilla or forum URL here, so that people can find your discussion from here. Thanks!!!

            Cheers,
            -Martin

            Comment

            Working...
            X