Announcement Announcement Module
Collapse
No announcement yet.
Sts + gwt Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sts + gwt

    Hi,

    I'm new to STS but when i tryed to used it with GWT via th Roo commande : "web gwt setup", STS builder throw me out some errors particulary with javax.validation library. For people who are in the same case as me, i found a solution ! Just right click on your brand new project, Google > Web Toolkit Settings... In the opened window, click on "Use Default SDK (GWT 2.4)" instead of "Use specifi SDK". Refresh your project and errors should be remove.

    Now you can run your application as in GWT tutorial, Run as > Web application. No need to use mvn gwt:run anymore.

    Hope it'll help !

    Regards,

    Version :
    STS 2.8.1
    Roo 1.1.5

  • #2
    Some more search

    Ok,

    So after some more investigation, gwt seems to need so librairy present in gwt 2.4.0 :
    - gwt-user
    - gwt-dev
    - validation-api-1.0.0.GA-sources.jar
    - validation-api-1.0.0.GA.jar

    I tryed to directly change version inside pom.xml from 2.3.0 to 2.4.0 but even more errors came up.

    To compile (works with mvn clean install and not with GWT compile, don't know the diference ...?) keep current pom.xml and do as said on the post before.

    If people have some explication or informations about thoose behaviors, i'd be thankful to know more about sts + gwt.

    Comment

    Working...
    X