Announcement Announcement Module
Collapse
No announcement yet.
WebSphere 7 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • WebSphere 7

    Which version of STS supports WebSphere Application Server 7 ?

  • #2
    Hi!

    The support for WebSphere Application Server 7 comes from IBM as a plugin for Eclipse and is therefore not closely related to a specific STS version. You should be able to install the WebSphere Application Server tools edition from the Eclipse Marketplace into the recent STS versions. Just install the Eclipse Marketplace client first (via the Dashboard) and then look for the WebSphere tools there.

    HTH,
    Martin

    Comment


    • #3
      Got an error when trying to install WAS 7 Developer Tools

      Thanks for responding, Martin. I ran into the following error message, I guess I need to install the Helios package and then try again?

      Cannot complete the install because one or more required items could not be found.

      Software currently installed: WebSphereŽ Application Server V7.0 Tools 1.0.0.v20111103_1518 (com.ibm.websphere.wdt.st.v7.feature.group 1.0.0.v20111103_1518)

      Missing requirement: WebSphere Application Common Server Tools UI 6.1.505.v20111031_1843 (com.ibm.ws.ast.st.common.ui 6.1.505.v20111031_1843) requires 'bundle org.eclipse.jpt.core 2.3.0' but it could not be found

      Cannot satisfy dependency:
      From: Shared Server Tools 1.0.0.v20111103_1518 (com.ibm.websphere.wdt.st.common.feature.group 1.0.0.v20111103_1518)
      To: com.ibm.ws.ast.st.common.ui [6.1.505.v20111031_1843]

      Cannot satisfy dependency:
      From: WebSphereŽ Application Server V7.0 Tools 1.0.0.v20111103_1518 (com.ibm.websphere.wdt.st.v7.feature.group 1.0.0.v20111103_1518)
      To: com.ibm.websphere.wdt.st.common.feature.group [1.0.0.v20111103_1518]

      Originally posted by Martin Lippert View Post
      Hi!

      The support for WebSphere Application Server 7 comes from IBM as a plugin for Eclipse and is therefore not closely related to a specific STS version. You should be able to install the WebSphere Application Server tools edition from the Eclipse Marketplace into the recent STS versions. Just install the Eclipse Marketplace client first (via the Dashboard) and then look for the WebSphere tools there.

      HTH,
      Martin

      Comment


      • #4
        Hi!

        Yes, "org.eclipse.jpt.core 2.3.0" is part of Eclipse Helios, so it seems like the WebSphere tools are compatible with Eclipse Helios 3.6 but not with Eclipse Indigo 3.7. In Indigo (that bundle doesn't exist anymore and got replaced with several other ones). Maybe there is a version out there of the WebSphere tools that is already compatible with Indigo.

        Otherwise you would need to install STS into an existing Eclipse Helios installation (from the Marketplace) and then add the WebSphere tools to it.

        But I guess there is somewhere an Indigo-compatible version of the WebSphere tools (maybe not a final version on the Marketplace, but from some other IBM pre-release site, don't know exactly).

        HTH,
        Martin

        Comment

        Working...
        X